ESC (BLH) Telemetry Matek 405 - Not Working


I cannot for the life of me get any ESC Telemetry working using a [HAKRC BLHeli_32 Bit 35A 2-5S ESC Built-in LED Support Dshot1200]

I have wired the factory wire to RX 5 which is serial 5 on the Matek 405

I can successfully connect to the ESC using the latest version of BL Heli Suite.

When running the test I get the following message;

21/09/2020 22:44:57 : ESC: Test PASSED
21/09/2020 22:44:57 : ESC: Prot 5 Good 62832 Bad 0 0 0 0 x0
21/09/2020 22:44:57 : ESC: BL_ReadBuf 16 -> 19
21/09/2020 22:44:57 : ESC: BL_SendCMDSetAddress 0xEB00
21/09/2020 22:44:57 : ESC: BL_SendCMDSetAddress 0xEB00
21/09/2020 22:44:57 : ESC: BL_ReadBuf 256 -> 259
21/09/2020 22:44:57 : ESC: BL_SendCMDSetAddress 0x7C00
21/09/2020 22:44:57 : ESC: Interface type imARM_BLB
21/09/2020 22:44:57 : ESC: BL_ReadBuf 8 -> 9

On serial 5 I have tried both Mavlink 2 and 16 in the Serial 5 Protocol.

Here are my settings;

Any ideas what I could try next?


I just made first attempt to connect ESC telemetry to Arduplane 4.0.6 and it doesn’t work as well as for Craig F. I have Pixracer FC, ESC R Fly Fort with BLHeli 32 V32.6. PPM is connected to Servo3 and I can configure ESC through FC. Telemetry out is connected to RX of Telemetry2 (Serial2) port, SERIAL2_PROTOCOL 16, speed 115200. Does anyone know what to do?
Edit: It seems I found it: I enabled “auto telemetry” in the ESC settings and it started working. @craigy72 Try the same and let me know, if that worked for you.

Hey Roman, thanks for this. I did try this actually and it didn’t work for me. It seems that there is definitely a bug with the 405 build as I have a 765 and it works fine on that FC.

Are you able to give me all of your settings and I will try the same. Be interested to see your SERVO_BLH_ settings


I’m bit confused what do you mean with bug in “405” because my Pixracer has F405 CPU and it’s now working on it - see here:
Are you sure you don’t have serial port numbering or RXD/TXD pin mismatch? On some targets is serial port numbering quite confusing and some wiring diagrams shows not RXD/TXD label of the actual pin, but where it should be connected to (which is the opposite). Check that once more…
Good luck!