ESC beeping continually

Hi all ,

I am a new user of pixhawk mini FC. I have used APM planner to install Arduplane 3.8 for a new project of FPV fixed wing.

After initial setup, all it is OK except ESC calibration. When I turn on arm switch, ESC beep continually ( this ESC works fine when is calibrated with the receiver)

After a lot of test and reading post about this issue I do not get solve this problem. I use Turnigy 30A ESC with BEC and I test other two different ESC ( kontronik and Simon). I have modified PWM minimum and maximum values in SERVO throttle channel without results.

Someone could help me? Are there some ESC kind recommended?

I do not use the arming switch but my Esc beeps after a while staying for too much time at idle without a valid pwm signal so arming the plane and moving a little the throttle stops beeping.

Have you try to arm the plane and if yes what happened ?

Yes, I tried it, but it did not work. I also tried to modify transmitter endpoints and neither. I do not had experience with pixhawk, but in my previous cc3d revo project I did not have any problem with the same ESC. Could be firmware problem?

I would be grateful if you would tell me some ESC brands that work well

Where did you connect the Esc on the Pixhawk ?

Have you check the configuration of the Pixhawk output ?

It looks to me that the Esc do not receive a valid Pwm signal because it is connected wrongly .

I have followed wiring docs from ardupilot. In fact, both servos works fine. I have asigned channel 4 for throttle,1 and 2 for elevons ( servos) and 8 for flight mode, and they are connected to correspondent pin out ( I can see this when I check the PWM signal from APM planner).
Actually I check this already and I think it is fine

Set BRD_SAFETYENABLE=0. Also set BTN_ENABLE=0. With both of these set to 0, the autopillot will boot up with all features active - and the motor armable - so be careful.

I have also verified that. Both values are 0 . When I connect the power with throttle stick to maximum ESC beeping and does not enter in calibration mode.

You cannot calibrate the Esc that way , with Pixhawk untill the system is armed no valid pwm is provided.

Calibrate your Esc via the Mission Planner configuration option or connecting directly the Esc to your receiver.

The system is armed and the ESC should enter in calibration mode by this way ( 2 or 3 quick beeps) . I have followed step by step ardupilot instructions

The ESC works fine when is calibrated and connected only with the receiver, but do not work with the signal provided by the Pixhawk ( according ESC instruction manual , signal too high or low)

Please read how Servo4 parameters are set

These are the current values