Errors when Writing WPs

Please I need to solve this problem. I’ve been unable to ‘Write’ my flight plan to the APM from the Mission Planner. After designing my flight plan, I try to Write it by clicking on the Write Tab on & I get an error with the following details… I took a screen shot of the error message… Please find attached the screen shot

thank you


Hi Wales,

I noticed your wp radius are big, overlapping with the radius of other wps, reduce the radius.

[quote=“RogelioN”]Hi Wales,

I noticed your wp radius are big, overlapping with the radius of other wps, reduce the radius.[/quote]

I just created a new flight plan with your advice & I noticed same Error but different details. from the 1st error it says; Timeout on read - setWP but after creating the new flight plan it says;Timeout on read - setWPTotal with different details. find attached a screen shot of the new error with the details

MP is timeing out waiting for a response from the board… check your cabeling, and you are not over subscribing the link.

Ok thanks I’ll do that immediately.
But please what do you mean by “you are not over subscribing”?

asking for more data than the link can provide.

does it work over usb?

[quote=“meee1”]asking for more data than the link can provide.

does it work over usb?[/quote]

Well the APM has a USB port so also the 3DR radio, its a version2. I actually have both versions 1 & 2, 900mhz radios. The base station (that’s the one connected to the computer via USB) is a version 1 while the other connected to the APM is a version 2. The initial radio connected to the APM on the drone is bad so I replaced it with a version 2. Now what do you mean by “does it work over usb?” ?

does it work if you direct connect the apm to the pc via usb

hello Walesz.
i got the same error too. did you solve the error?
thank you

I use APM 2.8 rover 2.51 beta with MP 1.3.77. I only clicked on “Read WPs”, clicked “Ok” in next window. After this this problem was solved.

I had same problem , tried read mission from FC first and now it writes new mission correctly .MP 1.377 . Thanks for advices posted from colegues

need more info

if its a APM, that is over 5 years old now, and no longer supported by the newest MP version


I found MP1.72 version and Arduplane version 4.2 firmware when I tested recently. When the software is connected to the data transmission after opening the software, it is easy for the software to suddenly close automatically.

The MP1.72 version I have been using before has been used with the Arduplane 4.09 version firmware for a long time, and it is very stable and there is no abnormality.

I don’t know what is the reason?

I would like to know is there a changelog release for each Mission Planner version update? Like an Arduplane firmware release?

Mission Planner version and flight controller firmware version are prone to incompatibility. It is recommended to indicate which versions of flight controller firmware are supported when the Mission Planner version is released.

The expectation is that you will keep your hardware and software up to date rather than languishing in years old versions…

I do understand the temptation to simply stick with something that works. In that case, it doesn’t make sense that you would update one (GCS or autopilot) and not the other.

thank you for the explanation.

I suggest that MP software can write a description in each version, such as which versions of firmware are supported and which versions of firmware are not supported, which can avoid many version compatibility issues.