Error with setting up SITL in Linux

[color=#004040][color=#000040]I just started ardupilot development and have been trying to setup SITL for Windows. I am at the Step 7(wiki) of setting up SITL using Linux. I keep getting an error " wp:command not found" whenever i use “wp load …/Tools/autotest/ArduPlane-Missions/CMAC-toff-loop.txt”.

I started with trying to setup SITL on Windows … n-windows/
which basically guides you to setting up a Virtual Machine with Ubuntu and installing the necessary files for SITL on Linux.

I am new to the whole UAV- Linux development environment and would appreciate any thoughts or help with regards to this.


PS: I have already checked for the paths in .bashrc and changed them accordingly as some of the mavproxy stuff didn’t get installed in the Home directory. I also ran the line endings fixes by doing the dos2unix.[/color]

I’m guessing something is missing or wrong in your setup.

The wp load command works fine for me.
I and some guys at RCG wrote a script and guides for SITL installation, which, at least for me, works fine.
I’d appreciate if you could try it out, to see if I missed something.

Thanks a lot! Your guide is perfect. I actually found it before you commented here. I tried the SITL installer and it works now. I just have to figure out the MavProxy commands. I was able to load the waypoints but unable to make the quad follow them. Can you help me with any of that ?

Thanks. :slight_smile: I had help. (A lot…)

Just guessing here:
You need to disable arming check ( param set ARMING_CHECK 0 )
Arm the throttle ( arm throttle )
Throttle up to take off ( rc 3 1700 )
Set mode auto ( mode auto )

Easier to do if you connect to MissionPlanner, and have a joystick connected.

The MavProxy docs and user guides are here:

I have been doing that. But for some reason, when I put it in ‘auto’, it just stays there instead of following the waypoints. I will try to figure it out.

Yes, I have started using the Mission Planner. I need to understand that as well. I don’t have a a joystick at the moment.

I also wanted to ask you if you are into APM development. I have been trying to setup Eclipse( to build the code and have been running into issues with the setup. Thanks in advance.

I’m sure you’ll figure it out.
Using MissionPlanner is a bit more intuitive. Try guided mode, or setup your own mission.

No, I’m not a developer, just a regular user.