Error when trying to download Mission Planner logs

Hello,

I’m trying to download a flash flight log through Mission Planner (Version 1.3.39 Build 1.1.6038.12291) and I get the following message:
“Mavlink 0.9 Heartbeat, Please upgrade your AP”

How can I fix it ?

what autopilot and version are you using?

Hi.

APM Copter V3.3.3 acf2e10c

Read this thread: http://diydrones.com/forum/topics/mavlink-problem

I’ve read this post before posting myself.
It’s not the same…The message in this post:
"Mavlink 1.0 Heartbeat. Please upgrade your mission planner"
Mine is different:
“Mavlink 0.9 Heartbeat, Please upgrade your AP”

Nonetheless, I tried launching MP with ArdupilotMegaPlanner10.exe and it didn’t help.

could you please upload your missionplanner.log file. its in the missionplanner install directory. ideally try to connect, then close mp, and upload the log.

Well, it’s not in the installation directory…As the bin file fails to download with the error message I mentioned…

I just tried to download the same log file through Mission Planner (same version / same build) on a different PC and it worked…
Perhaps there’s something corrupt with the MP installation on this particular PC

sounds like it yes, try a reinstall from the msi. almost sounds like it doesn’t have write access to the MP directory, you could try running MP as administrator.

1 Like

I’ll try that.
Thanks!