Error when building APM using make on windows(cygwin)

Hi All,

I am having a problem trying to build ardupilot code using make for windows tutorial. I am not sure whether it is a filepath issue or something else. I have been looking at a few other online sources with similar problems. I tried a few possible solutions but have still been running into this problem. Here is a link to one such issue with a solution!msg/drones-discuss/YooljrxL36A/WgXk44nqcI0J

I am able to build the code using the make tutorial for pixhawk but failing whenever i start using the arduino development environment.

Here are the details:(also attached the for reference)

$ make
building /tmp/
%% ArduPlane.cpp
%% ArduPlane.o
avr-g++.exe: error: /tmp/ No such file or directory
avr-g++.exe: fatal error: no input files
compilation terminated.
C:/Users/Vayu/Documents/GitHub/ardupilot/mk/ recipe for target `/tmp/’ failed
make: *** [/tmp/] Error 1

Also, the reason I got to using make is that I was using the Eclipse tutorial and realized that it uses Make to build the code. So, my end goal would be to run run Eclipse IDE to edit the code and understand it better.

Thanks in advance!

I did a lot of things to finally get it working but I believe including python.exe path in the environment variable of windows made it work.

I met the same problem with you, I had read your artical, but my problem did’t solved, can you help me, please?
My PC operating system is WIN7, and I add the path “D:\cygwin\bin” into the environment variable “PATH”, because “pathon.exe” was included in this directory. Did I right, please?

Looking forward to your reply.
Best regards.