Error receiving log list (trying to D/L logs from Quad)

I’m running Mission Planner v1.3.30 build 1.1.5648.36304 ArduCopter V3.1.2 on Win7 64 bit and plugged into a Cheerson CX-20 Auto-Pathfinder Quadcopter. The Mavlink works just fine and the quad connects to Mission Planner just fine and MP loads in all the params from the quads FC. When the quad gets a GPS lock Mission Planner picks up the location and pulls up the appropriate satellite image showing me exactly where I am and the artificial horizon tilts or levels in real time as I tilt the quad. So data is being transferred just fine thru the MavLink. When I try to download the logs I get a small-pop window with these words, “Error receiving log list.” I noticed a new message in the Messages tab on the left that states, “No dataflash inserted.”

When I try to do a compass calibration via MP, I get two pop-ups with the first error message says, “Set COMPASS_ORIENT failed” followed in a few seconds by still another pop-up stating, “Error setting parameter.”

I get a similar type error when trying calibrations within MP. My first thought would be that there’s a connection issue between quad and PC, but everything else suggests that this isn’t the problem Maybe the internal memory for the Flight Controller (micro-USB) has gotten corrupt and it needs a reformat or erasing of all data, after the necessary saving of current parameters. Isn’t there a reset button on top of the FC? Would that help?

Thanks in advance for any troubleshoot help or assistance you can provide, cause lord knows I need it…

Cause I’m just a…

Maybe I just got lucky, but I figured out the solution to my problem, which I now present here to assist others who might have a similar problem.

Prior to doing this solution, I really couldn’t do much of anything in Mission Planner. I couldn’t do any of the calibrations, couldn’t download any logs, and I couldn’t even alter any parameters. What I did was go into the Terminal option, which you’ll find along the top menu bar of icons. Once in terminal mode I clicked on the rectangular CONNECT button in Terminal (not the main connect button, I’d already done that). I also clicked on the TESTS and SETUP RADIO buttons, which enabled logging (I think) and pretty much everything else.

Because after I did these in TERMINAL mode I was able to go into Initial Setup and run thru all the calibration tests which also fixed a number of issues I was having, such as the TX not always arming the motors (I’d have to change modes try arming, switch back to manual, and after a few switches here and there I’d end up getting the motors armed, but now it does it right away by moving the throttle control down and to the right - like it’s supposed to do).

I’d had trouble with LOITER mode and RTL? Forget about it before, I wasn’t even going to risk a fly-away. Now all modes have tested out perfectly and RTL is so accurate that the last time I used it the quad nearly landed on top of me.

Maybe someone can enlighten me as to what I did exactly or why I had to do it, but right now I’m just tickled to have everything working beautifully.

Next Up: A way point mission.

Terminal mode is disabled in the next version as it uses up Flight Controller resources… You can not download logs through Terminal screen. This is not supported anymore.
There is an option on the HUD screen under the DataFlash Logs tab, use that option.
This only works when connected by USB cable. Other function will work by radio or USB cable.


Yes, I have tried downloading the log file via the Flight Data screen and then I clicked on the tab marked, “DataFlash logs” Next up I clicked on the option to “Download DataFlash log via Mavlink.” It appears that I’m still getting an error when trying to download logs, “Error receiving log list.”

One thing I did notice was a message that said, “No DataFlash Inserted.” Are the logs saved on some kind of SD card and is mine maybe not there OR needing formatted?

If you are using a Pixhawk, the logs are stored on the 2Gb micro SD card in the card slot in the front of the Pixhawk.
If you are using a APM2.x the logs are stored on an internal SD chip. If the APM 3.3vdc regulator goes south, it may affect that internal SD chip.

Thank you, sir. I don’t think my voltage regulator has or is going south, since this is the singularly only issue I’m having with my CX-20, I don’t think it would be the voltage regulator.

So the SD card is on the inside for an APM2. Is it accessible at all or without destroying the FC? Is there any kind of command prompt I could use to possibly format it check it for errors/issues? It seems to be acting like a bad SD card, but I’m not sure of what could have caused it to go bad.

It’s not a card, it’s an eprom chip soldered to the board. Think the only way you can erase it is from the “erase logs button” on the log download page in mission planner.

Well, I don’t think I’ll be replacing the EPROM and I’ve already done a dump of the log files, which I think is the closest MP gets to “erasing logs” and that didn’t do anything really because there aren’t any logs to erase. That’s one of the reasons I’m not getting any logs, because it doesn’t appear to creating any. Maybe THAT’S the issue, the logging isn’t enabled somewhere. Is that a parameter I need to adjust?

What is your LOG_BITMASK parameter set to?

What is your LOG_BITMASK parameter set to?
TCIII AVD[/quote]
Funny you should ask, because just before coming out here to update my issue I had done a bit of a test. I’ve got that message that tells me “No DataFlash inserted” or “Dataflash not inserted.” It sounds to me like a potential EPROM failure or memory failure for the FC.

I figured a good test would be altering one of the parameters, write parameters, disconnect from MP and then reconnect and let it load the parms and see if my altered param was still at the altered variable. So I’m going thru the params under “Standard Params” in MP and I find the one you mentioned, LOG_BITMASK with a description of “4-byte bitmap of log types to enable.” Mine has an entry of “Disabled,” which I learn should be 830 (I think) or in verbage “Default.” I changed that value to Default, selected “Write Params” and then hit the disconnect for the MavLink, wait for the LED’s to go back to their usual blink pattern and then I safely disconnect the USB cord from my quad. Wait a couple of minutes (let any caps holding charge drain) and then reconnect to MP and check the param and it’s back to “Disabled.”

I tried it several times to no avail, it just keeps changing back to “Disabled.” Unless I’m totally missing something or doing something totally wrong, I think the only way to fix this is with a new FC.

It looks like I’ve gotten my answer, unless anyone has something that has been missed. I learned that just because my DataFlash memory is bad or non-functioning doesn’t mean I can’t still calibrate all the needed parametrs (accelerometer, compass, tx, auto-trim, auto-tune, etc.) and get those to save, but I can also still create and execute Way-Point missions (we’ll be testing this one very soon). If I were to get a wireless telemetry unit and connected that to the APM2.5, then I’d have real-time mission log info and could save that data if I wanted to create a mission log. Most importantly I’d have that data available WHILE on a mission in real time, rather than having to wait until after the mission is over to read the data.

Unfortunately when the DataFlash memory fails there is no option for repairing. This won’t affect the FC features or performance nor affect any available flight modes or auto-pilot settings.

Thanks to those of you who responded. I greatly appreciate your assistance. It isn’t always about learning all the things that you can do, but it’s also about learning what you can’t do OR what you shouldn’t do.



I have the exact same problem, word for word.
Have you found a solution?

Kind Regards,

I had the same problem on a Pixhawk and solved it by buying a new SD card for the pixHawk. The APM hardware does not have a removable memory device, so you may have to buy a new one or repair the hardware.