Error on make sitl on Cygwin


I am trying to build AurduCopter at CygWin and I am getting ArduCopter.elf failed when i try toi execute make sitl -j4. Any fix for this issue?

Below you have the log

%% motors.o %% Log.o %% inertia.o %% control_poshold.o %% control_rtl.o Building /tmp/ %% ArduCopter.elf /tmp/ In function ZN15DataFlash_Class20Log_Write_ParametersEv': /home/uri/ardupilot/libraries/DataFlash/LogFile.cpp:718: undefined reference toDataFlash_Class::Log_Write_Parameter(AP_Param const, AP_Param::ParamToken const&, ap_var_type)' /home/uri/ardupilot/libraries/DataFlash/LogFile.cpp:718: undefined reference to `DataFlash_Class::Log_Write_Parameter(AP_Param const, AP_Param::ParamToken const&, ap_var_type)' collect2: error: ld returned 1 exit status C:/cygwin/home/uri/ardupilot/mk/ recipe for target '/tmp/' failed make: *** [/tmp/] Error 1


I just tried this again and everything worked fine. This makes me thing that the issue is due to a missing dependency, rather than incorrect code. All I can suggest is very carefully checking that you did indeed download all the libraries mentioned in the documentation (in Cygwin).