Error message trying to download Dataflash log

Hi all,

When I try to download dataflas logs from my Pixhawk1, I get this message:

Does anyone know what does it mean?

Firmware is Arduplane 4.0.7


How did you connect to the pixhawk? Usb cable or telemetry?

Hi @Mustafa_Gokce,

First I connected to the Pixhawk through a usb cable adapter like this one:
usb cable

And then connected the USB cable directly to the Pixhawk (a different USB cable).

Both times I got the error message

1 Like

Sometimes I see this issue. When I arm the vehicle and then immediately try to reach the log list, I could be able to see the logs. Could you please try it? It might help. Absolutely unplug the battery and power the board with USB cable only. Let me know if it helps. Regards…

Hi @Mustafa_Gokce,

I tried again but got the same error message. Thanks four your response.

Maybe is related to the SD card.

Have you removed the SD card and verified that it is indeed logging data?

1 Like

Hi @Allister,

Removing the SD card and using a USB adapter to connect it to the PC, I could download the logs, thanks!