Error Flight mode 5 Loiter

Good Evening,

I come here since I ran out of Ideas and hope that somebody can look at one of my logs.

My quad flew fine a few days before (Loiter,Auto,RTL worked well) however i had some issues with Bad AHRS, Accel not calibrated an others. It didn’t let me arm. No green or blue light.

I was trying all kind of solutions i found on the Internet to solve those Problems.

  • Switching off IMU2
  • I was testing the Capacitor for the second IMU like suggested in a Forum Post.
  • I mounted the Pixhawk on foam to reduce Vibrations, still not perfect but I’m in the process to reduce Vibrations.
  • recalibrating every sensor multiple times
  • Inspecting the Pixhawk board for solder problems

Since I mounted the Pixhawk on foam and reinstalled the firmware those Errors of not letting me arm the copter are gone.

But since then I have some Issues when i try to fly in Loiter.
It will not engage, and the Pixhawks emmits a double beep.

I would appreciate if someone could look at my logs and tell me if there is something I can do.

Thank you


-Pixhawk with external GPS
-Copter 3.3.3

err flight mode.BIN (163.5 KB)

Logging is messed up. Need to set logging.

The most likely problem with flight mode with double beep is poor GPS lock.


Hi Mike,

I uploaded the wrong File by error.
Please take a look at the new file.



Your problem is your GPS. In order to use GPS modes the HDOP must be below 1.4. Yours is at 2 or greater. Satellite count is also low at 6 or 7 total.


I was flying the last few days again and suddenly everything was good again.
Same location, same settings and no changes whatsoever.

Maybe the GPS just had a bad day.


Hello every body
I have a problem that I like to mention here and look for the solution

in a day I attempted to fly the quadcopter equipped with 4 antigravity motor and pixhawk + 40 A speed controllers and 6s battery

first I connected the autopilot to the computer through mission planner and it recognised our location

then I tried to arm the copter in loiter mode but I could not
so I armed my copter in AltHold mode and took off. several time I changed the mode from the AltHold to the Loiter in the sky but it seemed that was not successful. as the position was not important for me I was flying while the mode key was on loiter (but it could not keep its location while the altidude was fixed). as I attempted to test the max velocity of copter and went forward in full throttle, the copter went out of controll, started to increase the altitude and go to every where it wanted (not me). when I reviewed the log I saw that the only error was flight mode_5
I will attach the log here and hope some body help me with this issue
any help would be appreciated
thank you so much2016-11-01 13-51-12 29.bin (2.6 MB)

@mfzavareh In a word - Vibration.

Had a mini quad do the same, flew ok until I pushed it fast forward and it went vertically ballistic.

Had to cut the throttle and wait for it fall near the ground before catching it with some throttle.

Check the logs and look at IMU/acc values and you will see what I am talking about.

it exactly happened when I was doing speed test and going forward in full thtottle

This is usually caused by high vibrations on the flight controller. It does not generate an error but you should see high vibrations in the log. That is what I see in your log. These vibration start to go crazy as the copter starts to eat itself. The stronger the wind the higher the vibrations become.
The only way to recover from this is to switch to Stabilize mode and cut the throttle.
Good vibration damping is require to stop this from happening.