Error flashing RFD900x with 3.01

I recently got to reading about the future S. bus passthru that rfd900x will be supporting so I decided to flash a couple I have on the bench with the newest firmware which is 3.01 one flashed without issue but the second will not take the firmware, the newest firmware upload tool shows its been flashed but then none of the light come on, until you unplug it then plug it back in. Only then does it show a solid red light like its stuck in bootloader mode. I try again to upload 3.01 but all it does is pull up the led status window. I am able to go back to 2.65 without issue but don’t want to flash the rest if it might be an issue.

I’ve not been able to get the firmware to work either @Matt_C. I was assuming it had slipped out a little earlier than planned, or was aimed at the new TX and DIN versions of DIN IO and hadn’t been fully sorted out for the RFD900x.

I’ve been trying to get hold of Seppo (or anyone really) at RFD via email for months with no luck, so I wouldn’t hold out hope for a reply on here any time soon!

Awesome, I’ll give it a go later today. Thanks for letting me know @Matt_C.

I downloaded the update package and the firmware bin - the update went smoothly and the radios still connect and work. Mavlink to MissionPlanner working OK, although havent actually flown with it yet.

I noticed that output power and NetID reset to defaults - some people will have to watch for this if using multiple radio sets and groundstations, or if you might fly where others are in range.

Probably other values would have reset to defaults, but I already had everything else at default values.


i have RFD868x modems which where working perfectly (firmware 3.38). Then I just out of curiosity changed parameters Baud: 1300 and Airspeed: 700 (i dont remember exactly) on local and remote modules. And since then they just doesn’t work. I also forced both modules into bootloader mode with connecting pad 9 and GND pin and then applaying power to the modul. Modules seems switched into bootloader mode by turning LED light into solid red. Then i pushed connect (comXX, 57600), hit Upload Firmware but still gives me notification “Couldn’t communicate with modem. Try power-cycling modem.” I really dont know what to do…hope some can help me…? Maybe i bricked modules.

***also for reference, when i both modules plug in the green flashing light turns into solid green. Means the modules connected to each other ?

thanks in advance for any hint , beacuse i don’t know what to try anymore…


You shouldnt need bootloader mode to do the firmware updates. Since they get a solid green LED you just need to experiment to find the baud rate they are using and set them back to something conventional.
Air speed has to be higher than baud.

If 57600 baud (64 air speed) is not enough for you try these settings I use:

115 baud
200 air speed
80 max window ms

Caveat: these settings work with RFD900’s I havent tried 868’s


thanks for replay…
problem is that I setup Baud: 1300000 and air speed: around 700000 but now after connecting with FTDI the max speed RFD900 tools 2.57 can offer me is 460800 baud but for my case i should need to choose this value: 1300000. But the RFD900 tools 2.57 doesn’t have soo high range. Maybe because my original RFD FTDI cable doesn’t allow such a high speed.

Maybe i should get an high speed FTDI ?

Upload into bootloader and overwrite with new firmware i hoped will solve this issue, and changed all parameters to default values. But now biggest issue no matter which revision of RFD tool I choose just doesn’t work (doesn’t let me upload again firmware).


do me a favour. Can you please make a screenshot of drop down list for Baud rates (2400, 4800, ,…) and for Air Speed rates (12, 56, 64, …) ?


I have a suspicion you need RTS/CTS wires connected for firmware flashing, but I could be mistaken.

There’s some channel and frequency settings you can’t or shouldn’t change. Stick with the basics.
And this is the settings I’m using now with RC control via SBUS and RTS/CTS (options not selected in this screenshot) and it’s good for downloading logs :slight_smile:


Note I’m also using TX Power 27 instead of 30, for a bit lower power than standard. I don’t need crazy range, and 27 goes through buildings, over hills, passed trees and off into the distance further anyone can see.

Added drop-down lists:




first of all a big THAAAAAAAANK YOU !!! You helped me to resolve the issue and now my radios works again as before :slight_smile:
I also noticed that I was focusing on 1300k bauds instead 1200k bauds (your screen-shot helped me a lot)
I almost gave up on trying to connect to the radios because nothing worked. I tried V2.57, V1.5, V2.0, V2.6, V2.20, V2.34 no success. Then I remembered that Mission Planner has also sik/radio GUI for radios and I tried there and magically worked.

And yes I noticed it is better not to dare to experiment a lot with these radios just do basic/simple setup.

this is my setup…

You mentioned that you are using also RC control over radios but seems your setup same as mine? You do not change anything else for RC control? How do you do wiring? Do you use joystick?

I also tried to select RTS/CTS on radios and on Mission Planner on PC but doesn’t work, so I m not sure if selected RTS/CTS in MP is enough to make it work or no? And how do you know if RTS/CTS is actually working? soo many questions … :rofl:

You might want to change the “Max Window (ms)” to 80 which is what I use. Experiment with that one to see what works best, try downloading small .bin log files.

With RTS/CTS it has to be wired up correctly at the flight controller end, it probably is if you are using a supplied cable. The ground station end definitely is if you are using the USB cable that came with the RFD radios. If it’s working it shouldn’t make any apparent difference, except improve reliability, and if it’s not working you wont get any data transmission.
The parameter you want is
BRD_SERx_RTSCTS,0 for none, 1 for RTS/CTS , 2 for auto (try to detect)

For RC control we use a TXMOD in the RC transmitter

It does RC to the aircraft RFD radio plus wifi to the ground station and yaapu telemetry scripts work on the transmitter. The RFD radios have a pin that is RC out (or RC in) for PPM or SBUS.



thank you for your feedback :slight_smile:
I will try these settings. I will also recheck RTS/CTS
My current setup is DragonLink for RC but i also want to try RFD TXMOD.