Error date for name LOG file

Hello,
My log file does not have the correct date in the file name.
For example, today the file should be called 2020-03-27 then the time, may if it is called 2020-03-24 then the time that it is correct.
My GPS sends the NMEA GGA, RMC and VTG frames, the RMC has the correct date.
My Windows system has the correct date.
Do you have any ideas?
Thanks
Ludo41

Log name is created from the dataflash log date (which you can see in the download logs window). The log date is coming from the gps date/time of the last gps entry.

That is ok, but why today 2020-03-27, Mission planner create log 2020-03-24?
My GPS is a survey GNSS who generate NMEA GGA, RMC and VTG frames, date is only on RMC frame and this frame has good date.

Time is good, only date has an error.

Could you post the log itself ?

It’s at my office, I post the log on monday.

1 Like

Hello,
Log this morning .log and .bin files:

2020-03-27 10-20-49.log (804.3 KB)
2020-03-27 10-20-49.bin (437.5 KB)

Log parameter:
2020-03-27 10-20-49.log.param (16.2 KB)

Log GPS this morning NMEA GGA, RMC and VTG:
log NMEA 2020-03-30.txt (34.3 KB)

Hello,
No one has any idea, why the date in the file name is wrong when the NMEA RMC frame gives the right date?

What I see it is not Mission Planner related. The log shows
GPS, 1325532520, 6, 465997400, 2098, 13, 0.9, 47.7806278, 1.0271213, 132.73, 0.01, 350.92, 0, 0, 1

tow 465997.400 and week 2098 converts to 2020-03-27:09:26:37 (source : https://www.labsat.co.uk/index.php/en/gps-time-calculator)

and the NMEA log shoes
$GPRMC**,094616**.40,A,4746.8376696,N,00101.6272949,E,000.013,309.7,300320,0.0,W,D*20
Which is 2020-03-30:09:46:16

So log file naming is correctly based on the date/time in the log, but I have no idea why is it different than the one in the log (which comes from UBX messages).

Thanks for your reply, I hadn’t thought of studying tow and week from Mission Planner Log.
But how tow and week are generate because this information doesn’t existe on GGA, RMC and VTG NMEA frame. Does anyone have an idea?

Hey - have you solved your issue ? my date is jan 1970 …

Hi,
Sorry I have not solved my issue.
Have you connect a GPS?
Regards

yes I do - i was flying yesterday and some of logs have proper date, some dont. I wonder, how do i know i’d have a proper log name if i do not have the wireless mavlink or I dont bring my notebook to the field