Error Compass Variance (only External Compass 1 enable)

Dear All,

Need a little help here. I don’t understand why the error keep coming although only 1 compass is enable.


  1. Error Compass Variance always appear once take off even i only enable compass 1 (external compass)


  1. Reflash the new firmware
  2. Compass recalibration (enable compass 1 as external compass only)
  3. Change another external compass and recalibrate.


  1. Quadcopter X formation
  2. FC: Pixhawk

I attached below the tlog files for you guys to investigate. Thank you in advance.

2017-01-27 12-28-43.tlog (373.7 KB)

HI there!
I am having the same exact problem: did you come to a solution??
Why even if second compass is disabled I still get Compass variance…

Thanks to everybody that may help us!

Have you done a Compass/Motor calibration?
Is your compass mounted well away from power wires etc?

The .bin file from the PH is more useful than the tlog.

Problem solved.

It seem there are lots of magnetic interference on my build. I used the cheap power distribution board from Hobbyking for my quad build. I remove that pdb and direct solder each of esc to the battery for clean current flow. Then i put my gps higher and away from all of the electronic component.

Now it works great.