Servers by jDrones

Error Channel 1 out of range

arduplane
apmplanner2.0
pixhawk

(Tim Squires) #1

Hi

OK, I’m stuck (again)…

I have three working fix wing survey planes and am setting up another but this one will not allow radio calibration.

APM Planner (linux) states “Radio control is not active or turned on” but I have a bound FrSky x4r and a Taranis with the configuration copied from a similar model.

I can see the radio is bound and the hear the beeps when the radio is turned on or off.

I have tried another x4r receiver (pinched from a working pixhawk plane) and a Flysky transmitter with a known working 6 channel Flysky receiver (pinched from a working quad) and they have the same symptoms. I’ve tried different cables without success.

There’s no green showing on the radio calibration or the failsafe APM screens.

The apm log states: “isRadioControlActive: Error Channel 1 out of range: rcValue=0.000000”

All servos and ESC work fine if I bypass the pixhawk and wire straight to the receiver.

I’ve tried ArduPlane 3.7 and 3.8beta. Parameters loaded from a backup of a working plane.

Any further clues/ideas/fixes would be most gratefully received. After a whole Sunday trying to fix this, please someone point out that I’ve missed something obvious and quick to fix.

Thanks,
Tim


(Matt K.) #2

Most frsky Rx need a jumper installed during binding to get PPM or SBUS out. Have you checked the x4r receiver manual?


(Tim Squires) #3

Hi, thanks Matt. I’ve just discovered the problem, it was a duff servo, I think. Rebuilt the plane from scratch this evening, testing every part. When I attached one of the 5 servos, the radio stopped working. Maybe a short? Maybe servo wired wrong way. Anyway, swapped out the servo and it’s working great.

Thanks again.