Servers by jDrones

Error: Bootloader reports OPERATION FAILED

Hello, I am getting this error when trying to upload a Firmware to my Pixhawk 1. I tried uploading a new Bootloader, Uploading with QGroundcontrol, everything failed.

Has anyone a solution?

Good day, your fc is found by your pc?
Maybe during the procedure you corrupted the bootloader loader.
there are two ways for recover it.
would you mind tell me pls the procedure you are doing for this update

İ click on the Firmware and it tells me to unplug the board, click ok, when İ replug it it is being detected, but then the bootloader reports operation failed, also in qgroundcontrol the update doesn’t work, the firmware on the board is not working and İ can’t connect to the board

ok… did you try to use mandatory option… it’s located under the option install firmware… if also this option doesn’t work the bootloader is corrupted and you must reflash it

do you have a screenshot? İ don’t see mandatory option in mission planner
İ tried reflashing the boot in mission planner by pressing crtl+f but also reflashing failed

the bootloader is corrupted… you must reflash it

I there a way to reflash it without JTAG connector?

Jtag is the right solution…you need an swd programmer like stlink but first you must solder an smd connector on the swd pads located on the top o the board, ive tested it with sd card…can work

Could you please tell me how to do it with the SD card?

i will prepare the files you need… which flight controller are you using

Servers by jDrones