Erratic Pitch input


I have a Pixhawk 4 Mini which are flying very erratic when pitch forward or backward. Pitch input on the transmitter is constant forward or back but the drone is “bouncing” as if it is having oscillations. During this the drone looses height quite dramatically.

I have reloaded the firmware with the latest stable version 4.4.4 and set the minimum settings just to get it in the air, so no auto tuning have been done. Looking at the logs, RCIN->C2, it does appear like the Transmitter is having an issue but I’m not sure if it is the transmitter alone.

There might be too much vibrations as well but I am not clued up enough on reading the logs.

Can someone please assist in reviewing the logs and give any suggestions on why the drone if having the erratic bouncing?

Hope the link works as the post is saying the log file is bigger than 4mb which it actually ain’t.

Thanks in advance

Kind regards


Looking at your logs I don’t see anything surprising.
Given that your are in Loiter flight mode, the drone is supposed to stop in place when you release the pitch input.

Plotted below are RCIN2 (red), desired pitch (blue) and actual pitch (orange), as well as GPS speed (green). Whenever you center the pitch input the drone leans in the opposite direction to stop. Actual pitch closely follows desired pitch in these maneuvers, so no problem there. After GPS speed drops to zero, pitch levels out as again. So I would say the cause for the “erratic bouncing” is the loiter flight mode.

However, you have a severe problem with vibrations including clipping. For reference: vibrations below 10 are good, below 15 are tolerable, above 15 are bad. Clipping is also very bad. Vibrations in X and Y are not perfect but manageable, mostly below 15. Vibrations in Z are brutally high, in peaks above 80(!), which causes the clipping.

The vibrations alone may be accountable for the high loss, but it can also be a case of needed barometer compensation as well.

Apart from that I found some not-ideal tuning settings:

  • you are missing IMU temperature calibration

I recommend to read and follow the How to methodically tune (almost) any multicopter using ArduCopter 4.4.x guide. Download the .zip folder with the param files from the guide, edit each file to suit your copter and upload them one by one as you read along. The guide tells you what to do and which file is needed at any given time. Do not skip any steps! All steps are essential for a good tune. Anything that might seem like a shortcut will result in a worse tuned drone in the end.

Thanks @Janno for the quick reply. I will try to sort out the vibrations as I have noticed something that might cause this and then sort the Barometer calibration.

Correct, vibrations are your first priority right now.

Barometer compensation on the other hand is usually one of the last steps on the way to an excellent flying copter, as stated in the guide I linked above.
Without IMU temperature calibration, notch filter setup, MagFit calibration, autotune and windspeed estimation it wouldn’t be a surprise if barometer calibration/compensation yields little to no improvements at all.