Err. Flight Mode -10


I am using a Pixhawk 2.4.8 with an external GPS/Compass. Disabled all compasses, and am only using GPS. The waypoints have successfully worked a few times, but now whenever I try to switch to auto mode, I receive an error, “Flight mode change failed.”
.log file:



Really it’s best to keep the compass enabled. It’s possible it might work without the compass if the vehicle is started pointing north but it’s not actually a supported configuration at this point.