Err-EKF_check-2 CRASH

I had noticed in my logs for the last few flights I was getting this error.
Test: Compass = WARN - WARN: Large compass offset params (X:-252.00, Y:20.00, Z:-341.00)
So, Saturday morning I re calibrated the compass… Then I went for a fly… Take off was normal, switched to POS Hold and flew out over the field. I released the right stick to start to hover and climb… The copter just continued to travel in the direction it was going… So, I pitched back and the copter started to return towards me. Again, released the stick and and she just kept coming… WTF… So, now I am all over the stick trying to get it to do what I want but it just seems to have a mind of it’s own… A few violent pitches and rolls and then just starts to fly away… I just throttled down from about 10 feet and let it crash… :neutral_face: Broke three arms (S900 clone, RCTimer RS900) one ESC and twisted a gimbal arm… Camera, Sony NEX7 had not a scratch… Gathered up the pieces and and came home, plugged into MP and could not connect… Long series of dots and dashes coming from the FC and a solid red LED. I took out the card from the FC and installed into the computer, I could see the files but could not open them. The next day, I tried again and was able to recover the log. Lots of EKF Chk Errors… (See link to log file below) I’m thinking its gonna be a few hundred in repairs… New Pixhawk and compos mod and three new arms and ESC and hope to be able to straiten the gimbal… There seems to be quite a bit of chatter on the APM forums about this type of problem and do not want to go through it again… I suppose a better pilot could have got down with less damage but none the less, it a confidence problem with the FC… Thoughts?

Hi, i’ve checked your log.
So first, you have pre arm check disabled and the failsafe driven by the gps on. This is bad and could lead to crash and fly away.
Second, you didnt log any vibration data, so no vibration analysis and thing became hard now to diagnose.
Third, if you had recalibrated the compass the values are the same you wrote so something went wrong.

So, back to data analysis. You have a LOT of EKF check errors. This “should” be related to high vibrations, but we have no vib data so we can only assume that vibrations were far too high and the algorithm failed.
What i dont understand is why EKF FAILSAFE triggered and you have EKF use off.
You than had a radio error (did you shut down the tx?) as ppm encoder did not put any values out for 2 sec and then triggered a radio failsafe. (but this seems after the crash as speed was 0)

So, set the right log bitmask to logging the right things.
Do not disarm precheck and expect to do not have problems.
If you disarm GPS precheck, disable also geofence and Failsafe.
The problem is, if you take off with a bad gps signal your home could be km away where you are.

Thank you for your analysis…

I have disabled Pre arm chks in the past but I am near positive that I re enabled them. I do have some prior logs I can can check. Also, Past logs have always had vib data… I guess I’ll look at that is the logs just prior to this crash as well…

I know that my last two or three flights had this, “Test: Compass = WARN - WARN: Large compass offset params (X:-252.00, Y:20.00, Z:-341.00)” happening

It just all seems strange to me that these things sort of started piling up… I have to wonder if data was corrupted on the FC.

Also, The FC has become bricked after the crash… Tries to boot but fails… I have tried every remedy that I have found on-line to get it started with no luck…

At any rate. New Pixhawk and GPS/Compass has been ordered as well as three new arms and one new ESC…

And so the re build begins…

The “Test: Compass = WARN - WARN: Large compass offset params (X:-252.00, Y:20.00, Z:-341.00)” mean your compass offset are too large and i would became a problem during flight. Remeber the maximum values are +150 and -150 for each axis.
I see that also your pixhawk internal compass has very large offset.
Consider to move the GPS a 10+15 cm above your central plate, with a gps mast like that.
Then made a new compass calibration (stay away during calib from metal)

For the bricked PX…
Did you know that if you pull out the SD The autopilot did not boot and you have the nuttx os console on the USB? Try that, pull out the sd and power the px, and see if you can connect via usb to the nuttx serial interface.

GPS/Compass is/was on a mast. This copter had been flying very well for quite some time. I had just happened to notice that compass error while spot checking logs. The three or four flight previews all had that error.

So, I decided to re calibrate. Was in the middle of a field no phone no nothing to throw of the cal.

I will look into the “nuttx os console” that is something new to me. Like I said, I have no trust in this FC anymore and will be replacing with new FC and GPS/cmps unit. But, I would like to look into the old one further just for my own understanding…

I feel it just went flaky on me…

Appreciate your input!