Err: 24-0 & 24-1 + 'copter erratic behaviour

After some problems with Err 24’s and a crash with v3.4.3 I loaded v3.4.4 and it’s a lot better. But I still had one 24-0/24-1 event at which point the 'copter went almost out of control for a second in the last flight, clearly visible on the attached log. 2017-01-08 13-35-03.bin (1.6 MB)

Is this something to worry about or is there something I can do to mitigate it?

Your GPS count looks as if it drops to 7 sats received during the error event. In inverse the HDOP increases to 1.2 up to 1.3 (which in and of itself isn’t that bad) but I bet the errors are related to a quick loss of sat count.

You ask how to mitigate. You haven’t let us in on how your vehicle is set up. What kind of vehicle is it? How do you have the electronics set up (this is important especially where compass and GPS issues are concerned).

As much info as you can pass along will make it easier for any of us to analyze. The biggest thing here is do you have the GPS mounted on the vehicle directly or do you have it mounted off the vehicle (like on a mast)?

I’m flying in South Africa so 7-10 satellites is normal, most we get here is about 11 and yes I can see how a drop can cause it to switch, what I am concerned about is the 'copters reaction when that happened, it lost direction and attitude for a brief period rather badly. I have another thread in the v3.4.3 section where I had multiple events and eventually a crash hence my worry. (Odd crash today - multiple ERR:24-0 and ERR:24-1 messages?)

The aircraft is a tricopter that has been flying for about 2 years now, going through the various versions of AC. It’s using a AUAV-X2 FC from The compass is mast mounted about 150mm above all power wires/components. GPS is also away from the rest of the components with a clear view of the sky. Not sure if it would make a difference but when the event occurred the 'copter was directly above a corrugated iron roof.

Could it be related to the new GPS autobaud and autodetection? This new function has added a little bit of headache I think

That could be it. If you were recording tlogs (via GCS) then you could most definitely see that in the EKF popup.

I had been running 3.3.2 with dual GPS and have been having the same problem where the GPS switches suddenly between the 2 GPSs and the quad just zoom away to the second GPS coordinates. HDOP on both are good and satellites on the primary are much higher than the ones on the secondary GPS when the switching occurs.

What are the criteria for the GPS switch to occur other than the satellite count and HDP?

Same error here on ver 3.4.4 did flight with some wind (5 mph) and encountered the same error 24, then 24-1 and quad was erratic to keep ALT jumping up and down and could never keep loiter or ALTHOLD or POSHOLD well almost crashed it with a difficult landing just one broken prop.
Also the same quad flew over 300 min with no issues on 3.4.4 rc1 . Will upload the logs later today .

I believe the logic uses GPS Fix quality (3D, DGPS, etc) as the first test and then just number of satellites as the second test if the Fix quality is the same.

Here’s the code:

I think I found out what happened on my system. The GPS1 and GPS2 status were both at 3 when the secondary GPS status changed to 4 causing the GPS to switch. The primary GPS status also changed to 4 much later causing a switch back to primary. The primary GPS is an M8N which is the ones that seems to be switching between 3 and 4 more often than the 3DR one. The HDOP of the primary and the Sat count of the primary were much better that the secondary but it still switched GPS.

Status 3 is supposed to mean 3D Fix
Status 4 is supposed to mean DGPS

But I don’t have a DGPS. Anyone know why it would switch between them and how to prevent it from going to 4?

@vkt62 DGPS includes SBAS. If you were flying with a u-blox GPS this indicates you picked up some form of SBAS (IE WAAS/EGNOS/MSAS). You can disable SBAS on a u-blox GPS by setting the GPS_SBAS to 0.

Thank you. I just found that parameter and will be disabling it.

Great news I’m flying also with 2 GPS , Primary one is m8N , and the second one is internal to pixhack .

Logs from previous flight errors 24 and 24-1 firm ver 3.4.4 (stable)

logs from same frame few days before no error 20 min flight (ver 3.4.4 rc1)

I keep getting these errors and can’t trust my 'copter as it does very weird things when this happens.

Today it flew off by itself for about 30m (100ft) while in POSHOLD mode, I have now disabled EKF2 and so far so good, no weird behaviour.

Same here. Losing trust in the flight controller…
Copter suddenly loses height in loiter mode. Had to switch into stabilize before it hits the ground. Very dangerous Situation.
Please fix, Whats your recommendation?

Flight log:
26.BIN (3.3 MB)

Not sure that loosing height is the same problem, mine lost position and attitude, are you getting errors at the point that it lost height?

I disabled EKF2 and the problem hasn’t re-occurred so far