Engine speeded unexpect up, don´t know why

Hi there,
I am using a PH2.1 with PX4Flow and a LIDAR TeraRanger One. Everthing is working fine, but sometimes the PX4Flow Sensor doesn´t booted correctly (caused by simultaneously suppling with power). So then I disconnect the PH from Power and reconnect it. After booting the PX4Flow Sensor should be reconized by the PH. A procedure I did several times. But this time I started flying and I reconized the Flow Sensor is not working. So I landed disarmed the copter with the Transmitter. Then I unplugged the Power-Cable from Power Module to the Pixhawk. Suddenly the Engine Speeded up which can be dangerous.

I don´t know why. Maybe I should have disarmed the copter with the safetyswitch as well!?
I am using a Taranis X9D Plus with X8R via SBus.
So now I am looking for the reason and for a better solution for rebooting the Pixhawk.

Thank you!
Best Regards

Post a log.from that flight, so that, the experts can look into …

Thanks for responding.
That make sense, but at the moment I don’t have acces to the Quad, so it will take maybe a few days.

Thank you!

Hi there,
so I downloaded the last Log file and tried to study, couldn’t find anything that helps me. But I am a beginner in checking logfiles. Maybe you can find something helpfully.
The file is to big to upload here so I put it onto gigamove:

This one is the bin file:

This one is the bin.log file:

Is there a way to reboot the Pixhawk via remote?

Thank you!

I just tried to precipitate the failure. But on the Desktop the engines don’t Speed up when I unplugg the powercable from the Pixhawk. It doesn’t matter how I disarmed the copter.

Maybe it could be an issue by the ESC? That they unload the capacitors after a longer flying time.

You can see the RC out Channels 1-4 (ESC input signal)
and your Input Channels for Yaw and Height, which are used to disarm the copter.

We can see a peak in Motor PWM Output at the moment where you switch to Stabilize Mode again.

Is the mentioned motor spin up part of this Log?
Are your Motors configured in such a way that they will not spin in low PWM range at all?

So then you will not see the issue in the log. This log ends with the disarm. You need to enable the logging function in disarmed state separately.

Hi Fi156,
that Looks great! Thank you, is there an other tool for viewing log filed besides MP?

Yes that’s correct. When I Switch back from AltHold or Loiter to Stabilized the Gas Channel is to high so the Motor Speed up a bit until I reduce the Gas Value back to a Floating Level.

I think so. I disconnected the PH from Power by unplugging it from the Power-Modul. The ESC has been still connected via the PDB with the Batterie. I wanted to reboot the PH because of an Bad OptFlow Health issue. I have to make sure that the LIDAR and PX4Flow powered before the PH to avoid this failure.

So when I unplugged the PH from the Power-Modul the Motors started running with full power I guess. Just for a half of second like this. I did this several times this way without any problems.

So I am thinking about how to reboot the PH via remote controll without additional Hardware. That could be something for the new Version of ArduCopter :slight_smile:

Thank you!