Enable Lidar in Alt Hold mode

I’m having trouble setting up altitude hold mode using a Lidar Lite V3 HP. I can see the measurements from the Lidar in APM/Mission Planner and is working properly but when I fly it doesn’t hold the altitude and it looks like if it was “bouncing” from the ground when I leave the throttle stick at 50% going to the ground slowly and then climbing up again and keeping this oscillation (my deadband is 25%-75% so it is supposed to be holding the altitude), when I didn’t have the LIDAR and I just used the Baro it kept a somewhat constant altitude with some small variation, I suppose this is normal butI wanted more precision and that’s the reason why I got the Lidar.
I’m very confused if I have to change any of the EK2 parameters (EK2_ALT_SOURCE, EK2_RNG_USE_HGT), I’m just interested in flying it in the Alt Hold mode.
The parameters I used for setting up the Lidar are:
I’m attaching the logs of the last two flights I did.00000083.BIN (257.8 KB)
00000084.BIN (521.6 KB)

Hi @NEO5555,

What is your parameters about EK2_ALT_SOURCE and EK2_RNG_USE_HGT ?

Hi. Did you figure out how to adjust this configuration?