"Enable compasses" checkbox is missing in Mission Planner -Mandatory Hardware- Compass

running Arduplane V4.0.5 in Mission Planner 1.3.70 build 1.3.7277.34800 , I cannot see the checkbobx that is usually used for enabling compasses. In the attempt to enable compass i set Compass_enable=1 in Full List Parameters, but I have no evidence if it is really working or not.
Has maybe this feature been removed ?

Thank you

Get the latest beta Mission Planner

I’ll try it. Thank you

Updated to latest beta release but the problem is not solved. Could it be a problem of graphic settings on pc or mission planner ?

Did you tried to check the use this compass checkbox ?

Sorry but i don’t understand your question.

I further checked in HW ID panel the list of devices_ID. I see that all Compass_Dev_ID are zero although set variables “Compass_enable=1” and “Compass_use=1” in Full List Parmeters.
Checked wires and connection on the board (Matek F405 wing), all seems good.
GPS sees 14-15 satellites indoor.
Nevertheless Compass cannot be calibrated: using Live Calibration, no white dots appear and no samples are collected.

1 Like

Nothing will happen without Device ID’s. Perhaps the I2C SDA/SCL are backwards?

Yepp, its a hw error, flight controller does not detect compass.

“unfortunately” I2C SDS/SCL are correct. I will check all pin connection again

Thank you

but the problem of why the “Enable compasses” checkbox is not visible still remains

Because there is no such checkbox ?
Compass is enabled when it detected and the driver is loaded, then you can select “use compass” checkbox to enable use of that compass. The compass_enabled should be 1 by default, and you should not change it unless there is a good reason, then you have to do it in the parameter list.
Edit : The compass enable checkbox were removed back in december.

Just for clarity I enclose the picture above with the red area where i supposed to find the checkbox i’m talking about.
As i questioned at the end above, you confirm that the feature were removed.
I was not aware of this.

Thank you

I’m looking at the source code. That checkbox were removed in a commit last december. https://github.com/ArduPilot/MissionPlanner/commit/80854c1b9a47128b7d77e2ebb01ff92b138f9fb4#diff-726b40eb12a3660f8e3f5242d3bbe2d0 because the MAG_ENABLE parameter was removed from recent Copter, and since it is 1 by default on Plane, there were no need for it. Here is the issue that was concluded to the change : https://github.com/ArduPilot/MissionPlanner/issues/2264

The reasoning is simple : The only place where a user would want to disable the compasses is when doing non-GPS navigation and the wiki setup guides specify to set the MAG_ENABLE parameter to zero (like here) so we don’t need any easy-to-use checkbox for the 99% of users who are not doing non-GPS navigation

1 Like

Now it’s very clear to me.
Thank you for the advice and links to the sites.


1 Like

I’m also running Arduplane on the Mateksys F405 Wing and can’t get the compass to calibrate. No problem with the Omnibus F4 v3.

for me compass calibration works on the wing with plane firmware 4.0.6 but not with rover firmware 4.0.0. still need to findout why.