Emergency landing on maiden because of strange behavior

A copter of a buddy showed a strange behavior during the maiden. We were about to do PID tuning, but it was not really possible. The wind was to strong for Autotune, so we put rate P on channel 6 and tried to do our best to tune it, but we could not even beginn, because the copter did some strange movements. When trying to stear it tumbled very badly and was not really controlable. Unfortunately my buddy flew way too high and did not listen to me telling him to come down on a lower altitude. After trying to get it under controll, he decided to put it down, by putting throttle to zero. So the copter had a hard landing in the dirt. No big damages besides the mindset of my buddy.
What I want to know now is, if there is anything in the logfile that could help me understand what happened during flight.

So I attached the logfile to this post.

The copter is a quad with 930kV Motors on 3S with 12x3,8 Props and a weight of 2.1kg.
FC is APM2.5 with Arducopter 3.1.

I uploaded a video if the flight. In this video you can see the wobbling of the copter.
I really hope, that someone can help me with this.
My buddy tried the APM on my recommendation. Before he had a Phantom that flew away.
So he wanted to try the APM, but after that first experience, he will return to the Naza. So he ordered a Naza and removed the APM from his copter. I’d like to use his APM now, but hav to know if it save or if the APM has some issues that caused those poor flight performance.

So please take a look at the video and the log file and tell me what went wrong there. It is really important for me.

Here is the video:


Not a single hint?
Where are the logfile experts?

A little disappointing when I post a logfile and a video and get not a single answer.

I’m not the best person to analyse a log file for you so I’ll leave that to someone with more experience. I would like to ask if you remembered to calibrate your ESCs? That’s a fairly common cause of things like this.

In general it’s been my experience that tuning doesn’t fix issues like this. A copter that’s set up well typically will fly just fine with the default settings. Tuning just makes it fly better.

So look for some of the common things like props that are out of balance, forgetting to set the range on the ESCs, a bad motor, a loose bullet connection etc.

If you tie the copter down outside and stand back you can bring the motors up a bit and tell if things are balanced. The copter should run fairly smoothly. I bet if you do this you will see it shaking. If so, find out why and correct it. But be very careful. Don’t go anywhere near it when it’s armed.

I also spin my motors by hand to see if the motor spindle or the collet is bent. It’s really quite easy to see by watching the hole in the collet. When you spin the motor there should be no movement left to right. The collet should stay centred as you spin the motor.

Hope this is helpful. Just a few things I’ve found from time to time.

I am pretty sure that you’d find out something by now if you tried, instead of complaining. :slight_smile: - there’s just so much wrong in the logs: voltage, current, attitude… and a very clear link between all.

The flight is ok, but voltage drops fast and at the end you are barely your PID’s are increasingly bad as motors get slower to get to the desired speed. you are at only 9.94v when the logs get ugly - that’s a cell voltage of only 3,3v .

You also say it’s 2.1kg , but your log show only 1,3Ah used by the time the battery is more than empty - unless your current sensor is VERY badly calibrated - you fly with a much to small battery like 3S 2.2Ah - or a defective, bigger pack.

Thank you both for the reply.

The copter was flown with a new 3S 4000mAh battery (Zippy Compact).
So I think it must have been something wrong with the current sensor. I calibrated it and at the bench about the range of 10A it showed the same value in the MP as it did on the Amperemeter.
So wether it is something wrong with the current sensor or the calibration, or the battery is allready dead on it’s first flight.

I just took another look at the logfile and graphed the current readings. I think you are right. Voltage drops really fast at the beginning.
Maybe the battery was not good.
But why does it cause this wobbling? The ECSs are SimonK without low voltage cutoff.
When I fly my own copter with 10.5 Volts or slightly below it still flies well. No wobbling.

In the log there are allready strange values on Yaw, Roll and Pitch when the Voltage is above 10.4 V. And as I remember the copter wobbled right from the beginning.

So was it really the low voltage?

If the APM is set up for perfection at normal/high voltage , the tuning simply won’t match another setup, or the thrust and responsiveness of each motor is, and always will be, influenced by voltage. Remeber the KV rating.
(you should calibrate at nominal voltage (3,6-3,8v/cell)

your I terms might have built up and then helped to overshot after a sluggish acceleration.

Finally, once you get that low and fluctuating voltage, it’s hard to predict anything, at one moment APM is relaxing on the throttle to keep altitude, and commanded extra power to one motor works fine, the next 3 motors are increasing, then the fourth may try to go even higher, but the collective load makes voltage sink instead…

O.k., sound logically, but this is not my first APM Copter.
I had so many APM Copters in the last 2 years and still have some, but no copter did something like that copter of my buddy.
When I fly my copters to a cell voltage of 3.4 there is not the slightest sign of any issue.
This copter showed some serious issues from the beginning with a voltage of over 3.5V per cell.
Take a look at 0:56 and 1:15 in the video. There you can see what the copter did when the pilot did a yaw input. In the log it is around line number 2150 to 2200 and 2600 to 2700 and 3800 to 3900.
When you acitvate YawIn and Roll and Pitch you can see what I mean.
So whenever he tried to yaw, the copter went crazy over roll and pitch.

I can hardly believe, that this all came from a voltage of about 10.4V. In the lines in the blog, I mentioned above, the voltage never dropped below 10V and I flew so many times with other APM copters with voltages close to 10V or even slightly below that without any issues.

I will place that APM onto another quad and try it out. Maybe there is something wrong with the APM. This could probably be, but I have no clue what.
So I will do a little bit of try and error.

Maybe it is the low voltage but way did’nt this happen to me ever before, as I flew so many different copter with different FCs and even different APMs (from APM1 over APM2 to APM2.5)?

Moving the APM to test it sounds like a good plan. I’m still betting on something mechanical though. Something like a dry solder connection on the PDB or a bad bullet connector.