Servers by jDrones

Elevons not available on Arduplane?

(Stanley Anak Suab) #1

Recently I installed the default recent 3.8 firmware using Mission Planner into Pixhawk PX4FMU 2.4 board for my FX-61 wing project. During radio calibration I clicked to enable Elevons but the software notification was “Elevons not available on Arduplane”.
Anyone experienced the same problem?

Thank you

Where do I configure roll and pitch exponential?
(Kikislater) #2

Method has changed and it was explain on arduplane. You have to deal with servoX’s parameters where X represent number. Now you set AETR on radio like a regular plane and it works well. It’s more easier now. You don’t have to tick the box in MP, MP is outdated for this function

(Stanley Anak Suab) #3


I followed the steps in
My steps are as following below;

  1. Check for servos function
    SERVO1_FUNCTION 77 -Done
    SERVO2_FUNCTION 78 -Done

  2. Check for Rc Input
    RCMAP_PITCH 2 -Done
    RCMAP_ROLL 1 -Done
    RCMAP_YAW 4 -Done

  3. In Manual Mode I tested the elevons mixing but its not working. Should be as easy as before where just check the Elevons and then proceed with the reversals if necessary.

(Greg Covey) #4

Did you arm the plane first? Also, try power cycling the FC and read the SERVOx_FUNCTION again.

(Stanley Anak Suab) #5

GregCovey Yes I did the arming first.
The motor spins when I push the throttle stick up. (Im using mode 2)
What I mean by elevons mixing not working was that when I (left stick) push elevator stick up and down only one side elevon moving and when I move the aelerons left- right only the other side is moving.
I think I missed something which I didnt set properly in the parameter list.

(Kikislater) #6

You have to play with servo1_rev, rc1_rev and servo2_rev, rc2_rev parameters

(Greg Covey) #7

Ahh, I see now. Yes, the elevon (or v-tail) setup can be annoying but it looks like you are almost there.

Step 1 was to use the Elevon Planes section in the Wiki.

Step 2 was to use the RC Inputs or RCMAP, which you have done.

Step 3 is to get the reversals right as kikislater suggests. Keep following the Elevon Planes section until you get to Servo Reversal. This section explains what to adjust. I needed to read it when setting up my mini Talon using v3.8.2 for the first time. The new procedure will soon become our old friend. Hopefully, Mission Planner will catch up to the changes soon.

Good luck!

(mpjf01) #8

And, thanks to help from other contributors here, I discovered, after doing that, that you may need to go right back to the transmitter and reverse the direction of travel of one or more of the control surfaces there, and then go through the routine described again in order to get the compensation directions correct.

Pixhawk Elevon Setup
(Stanley Anak Suab) #9

Hi All,
Thank you for the replies. Now I got my Elevons mixing working. What I did was;
First I make sure that my Radio Elevons mixing are working by directly connecting the servos to the reciever and do the reversing in the radio.
I watched in youtube video done by painless360 that actually SERVO1_FUNCTION 4 & SERVO2_FUNCTION 19 number code for elevons and not as mentioned in as number code 77 & 78!!!

Now leads to another problem which is in FBWA, the elevons does not counter at the right directions. When roll to left and right only the right side elevon is moving and nose up nose down only the left side is moving! What could be the problem?

(WickedShell) #10

@Stanley_Anak_Suab FUNCTION 4 is aileron, and 19 is elevator. If you set this on your eleveon’s then it isn’t a surprise it is not working correctly. I can confirm that on 3.8 that the FUNCTION 4 is definitely aileron, and 19 is definitely elevator.

(Mike Boland) #11

I am currently setting up a couple of wings with elevons.
It’s easy to get tied up in mixing, but I found it straight forward by following the wiki.

Tx set to normal aircraft, no mixing.
Set your servos_function to 77 and 78

That’s it.
Mine worked straight off, with a bit of tweaking on the reversing (in the pixhawk)

Set it up like this in manual mode then checked FBWA and all worked.

(Stanley Anak Suab) #12

@mboland Thank you for your comment. Maybe I should try set my Tx to normal aircraft no Elevons mixing. Im using Futaba T8J. I have not tried this method yet. :smiley:

(Stanley Anak Suab) #13

Helo Guys,

:smiley: With the help from you guys finally I found the right way to get my Elevons working.
The steps are as following.

  1. In the TX set to ordinary aircraft setting no need Elevon mixing (Im using futaba T8J) *might be different setting for other TX.
  2. Follow the steps here (setup for elevon planes & the RC inputs and servo outputs.
  3. Radio calibration (Pitch reverse), in full parameters the RC1 & RC2 no need reverse, SERVO1 no need reverse & SERVO2 reversed.
    Thank you very much

(Ist1) #14

Many thanks for sharing your solution! I’ve gone through pretty much the same string of problems you did.

(Stanley Anak Suab) #15

@janoist1 You are welcome :smiley:
Ya, the 3.8 almost completely different from the previous version. Pls read carefully the guide before doing your project. Of course not all details is covered there depending on what hardwares you are using but you can ask in the forum here so all of us can learn like you did from my topics. thank you