Elevon not working even though everything else does

Hi All,

I was wondering if anyone out there could help with an elevon problem? I’m building an X8 and thought it was all good to go - I tested it on a bench board before putting it in the platform. Elevons and throttle all working correctly, Pixhawk arming as expected, good GPS etc. I had full control in manual mode and in the auto modes, moving the airframe displayed the expected shifts in the control surfaces.

I then installed everything in the aircraft and low and behold - Throttle works, elevons don’t. I Googled the issue and found one other similar article which was ‘closed’ with no apparent solution.

I tried connecting the servos directly to the receiver and everything works as expected - full movement. It just doesn’t seem to work through the FC.

I’m running a Pixhawk 2.1 with Here. Ardupilot 3.8.4. Taranis TXer and X8R (servo cable running from RCIn on PH to SBUS on Rxer).

I tried regressing back to 3.8.3 and 3.8.2, loading Rover in between to try and ensure it wiped correctly. I’ve been saving my Params with a bit of version control and have tried them all - no joy.

Had a look at the log file (I am new to all this) but managed to find the Servo1-4 and RC1-4 logs and they both show movement on the Elevator, Airleron, Throttle and Rudder (for arming) channels.

In summary - worked before, doesn’t work now - don’t think its a servo issue as they work direct to the receiver.

Any help would be mega appreciated - if the solution is obvious, apologise for the newbie post!!!


I used Arduplane 3.8.3 on a wing with elevons. The RC transmitter has to have plain default handling of aileron and elevator; the elevon function only gets programmed in Arduplane. If you are getting elevon type of operation when the servos are connected directly to the RC receiver then you have to remove the elevon function from the RC transmitter.

Send plain AETR from the RC transmitter, and then set these ArduPlane parameters:

SERVO1_FUNCTION = 77 left elevon
SERVO2_FUNCTION = 78 right elevon
SERVO3_FUNCTION = 70 throttle

Good luck,


Just a very basic and quick question: have you provided 5v to the servo rail on he Pixhawk?

As you might or might not know, the Pixhawk doesn’t provide power to the servos itself. (The RCIN is an exeption, and does have power). You’ll need a BEC connected to the servo rail.

Thanks Paul - I’ll give that a go.