Servers by jDrones

Elevon Mixing Problem

I’m trying to set up the elevons in a flying wing with an APM running ArduPlane 3.4. The transmitter is set up as for a normal plane without elevon mixing. I have servos plugged into output channels 1 and 2 and the throttle in channel 3. When calibrating the radio I have “Elevons” ticked in the Elevon Configuration panel. But the two servos work as separate aileron and elevator. What am I doing wrong ? This topic has been aired before but I haven’t seen a satisfactory answer.

please try ELEVON_OUTPUT,2

Thanks for the suggestion korakora. I did have ELEVON_OUTPUT set to 0. I have changed it to 2 but it makes no difference. I have ELEVON_MIXING set to 1 and in Radio Calibration “Elevon” is ticked.

I have found that although in Manual mode the two servos just act as separate aileron and elevator, in FBWA they do act as elevons. Perhaps there’s clue there.

I have it sorted with the following settings

ELEVON_MIXING 0
ELEVON_OUTPUT 3

I also needed to reverse the pitch in the radio calibration screen.

No mixing in the transmitter.

I should add that nothing is ticked in the Elevon Configuration panel on the Radio Calibration page.

Servers by jDrones