Servers by jDrones

Elevon config greyed out?

Hey all. This is my first plane. I have lots of experience with copters. I’m setting up a wing, and set the elevon outputs as they should be. That said I can’t tick any of the elevon boxes in the radio cal page? I’m on the latest beta MP and latest master firmware on a black cube. Any idea what’s going on?

Hi,
Assign the servo outputs on the netx tab: “Servo Output”.
Or take a closer look to “full patameter list” and set the belonging SERVOx_FUNCTION to 77 or 78 for left and right elevon. There is nice howto:
https://ardupilot.org/plane/docs/guide-elevon-plane.html

Good luck!!

1 Like

Yes. It’s a good idea to get in the habit of configuring in the Full Parameter list. Definitely true if you are running Master firmware where the GCS may lag behind even if it’s Beta. Menu’s, checkboxes, meh :slight_smile:

1 Like

You got it!!! :slightly_smiling_face:

I forgot to add Wizards. Down with Wizards :smiley:

2 Likes

This settings changed since version 3.8 of plane when RCx and SERVOx were separated … May be not updated in mission planner

1 Like

@kikislater Good catch.
Out of curiosity I plugged in a good old 3DR APM2.5 with Plane3.3 on it.
The Elevon config still works!!
That’s “backward compatibility” :wink:

I will call it windows like interface … for windows users only

1 Like

That’s like finding a Palm Pilot in the junk drawer and realizing it still works :grinning:

1 Like
Servers by jDrones