Servers by jDrones

EKF3 Waiting for GPS config data


(smithy) #1

Hi all,

I have a small quad with Copter-3.5-rc3, I am constantly getting “EKF3 waiting for GPS data” does anyone have anydea how to sold the error?

Thanks


(Thorsten) #2

Is GPS_AUTO_CONFIG set to “1”?


(Matt) #3

I’ve noticed that if you have EKF3 enabled, it does take longer to clear prearm checks. It is doing a lot of checking and verifying of sensors. It is much more picky than EKF2 or plain old INS. It is also an additional layer. INS does its thing. Then EKF2 does its thing. Then EKF3 does its thing. So the prearm time is indeed longer.

One of those things I see it being very picky about is the GPS. So if it is just taking a little while longer, I would say that is normal. If it is never satisfied and never gets beyond waiting for GPS data, something is wrong.


(smithy) #4

My GPS_AUTO_CONFIG is set to “1”


(smithy) #5

It never seems make it beyond EK3. My error seems to come from line 80 here.

Any recommendations on how to troubleshoot?


(Matt) #6

My guess would be your GPS isn’t providing the configuration data the EKF3 is asking for. What GPS are you using? I don’t think I’ll be able to determine if it is compatible or how to fix it. But based on the code and my experience with EKF3, I suspect that’s what is going on.


(Francisco Ferreira) #7

Aren’t you getting more detailed messages from GPS? If you are using Mission Planner check the Messages tab to make sure you are seeing all messages.

Also check your GPS_TYPE and GPS_TYPE2 parameters.


(Fernando Cunha) #8

Hello to all , same thing here. The messages appears whenever GPS_AUTO_CONFIG is set to “1”. If you set it to 0 the messages are gone.

My gps is a Banggood M8N ( clone ) but the latest time I flew with 3.5.0-rc2 or 3 I haven’t seen this message.

Any Clue? Maybe this is the normal operation…

Messages in the terminal doesn’t show anything other than that related to GPS.

Thanks


(WickedShell) #9

EKF3 sizes buffers appropriately based on expected GPS lag, with a u-blox device this used to mean we had to wait till the GPS was configured (which is ~10+second process on u-blox) before the EKF would boot.

This has been patched on master to allow the EKF to boot the moment we know what the GPS lag term is, however that will not be going out as part of Copter 3.5 (but will be in Plane 3.8)


(Fernando Cunha) #10

Thanks WickedShell, so what should I do to test EKF3? Disable GPS autoconfig ?


(WickedShell) #11

@tabascoz I would definetly leave GPS autoconfig enabled. It is resulting in a better and more tuned EKF buffer size for your aircraft, and ensuring that the GPS is behaving as it should. You should still be booting in the end, without the recent patches it is just a longer time for EKF3 to boot.


(Fernando Cunha) #12

OK Thanks @WickedShell , Will try that this weekend, will get back with the results.