Servers by jDrones

EKF Yaw Reset Uncommanded Yaw Issues


(Travis Bridges) #1

Im sure I have setup something wrong, my quad plane spins wildly. I have tried re calibrating the compass, moving the compass further away from motor wires, using EKF3, Im not sure what I have done wrong. Any help would be greatly appreciated.

https://drive.google.com/open?id=1oIJtPrREXikvwx3ARg2dxsneYKc8aN8H


(Jace McCown) #2

3.9.5beta2 looks to have a fix for this, is your FW up to date (mine isn’t, lol)


(tridge) #3

Hi Travis,
It looks like you have the motor spin direction wrong. You have Q_FRAME_TYPE=1, which means “X” frame, which means front-right motor spinning counter-clockwise when viewed from above.
Based on the flight behaviour I think you have an ‘H’ frame, which has the opposite spin of motors. To fix just change Q_FRAME_TYPE to 3.
Note that depending on the twist in your frame, it may fly better with X or with H, but please start with the simple change of changing the parameter and see how well it flies.
Cheers, Tridge


(Travis Bridges) #4

X is how I have it set up.

  1. Front right CCW
  2. Back left CCW
  3. Front left CW
  4. Back right CW

So I don’t think its that.


(Travis Bridges) #5

I just uploaded the firmware from MP this morning. So I believe I am on 3.9.5 stable


(Travis Bridges) #6

I uploaded Arducopter 3.6.5 and got the same issue. This leads me to believe I have a hardware issue.

Here is the log for that in case anyone has any other insight.

https://drive.google.com/open?id=1oIJtPrREXikvwx3ARg2dxsneYKc8aN8H


(Travis Bridges) #7

Just wanted to update here, I solved my issue. I had some twisting of the quad motors, as well as relatively under powered setup. Fixed the boom arm twisting, and moved to 4s solved my issue.