EKF variance error in altitude hold mode without gps

I am using Solo (pixhawk + copter3.3 i believe) for indoor application. I followed Indoor Flying Guidelines and changed the parameters uisng APM Planner. However when i pass command to takeoff in altitude hold mode I get EKF variance msg and then the uav disarms the motor and does not takeoff. Any idea how I can disable this behavior?
I did the following parameter changes:
ARMING CHECK [-9] ignore GPS check
AHRS_GPS_USE [0] use dead reckoning
FENCE_ENABLE [0] - disable

Hi I am trying to do something similar to you, but I can’t even get my Solo to arm. It keeps displaying Bad Compass Health and PreArm Need 3D Fix. I set all my parameters to the same as yours, I was wondering if you have any idea what I am doing wrong?