Servers by jDrones

EKF Status stays red

Hi,

I am trying to setup my omnirover, but for some reason, EKF status stays red, with “velocity horiz off” and “pos horiz abs off”
Sometimes the errors clear after a random amount of time, but yesterday, after I changed the Ublox 6 GPS for a Neo 8M, the error did not clear after 2 hours. The rover had a GPS fix with 12 sats and a hdop of around 0.9. My other rover has wheel encoders and does not show this behaviour. The other difference is the rover with encoders is using EKF3. Both rovers are using a Pixhawk1 with ChibiOS (RTFHawk and Pixhawk 2.4.8)

Hi Count74,

i have the same issue, all have been worked, so i have wired and installed all after installing i got the same errors. :frowning:
Do you have solved your problem?

You just need to wait a bit and the rover needs a solid GPS fix. It is almost impossible to get the error to clear indoors or between higher buildings, but in an open space it clears after a few minutes.

Hi Sebastian,

it isnt Working.
I Think the Here GPS compas ist damaged. When i holt them up the Compass is working. When i spin it around his own, he do nothing.

Re spinning around just the GPS/compass unit (and not the whole vehicle). This will likely not cause the vehicle’s heading to change. Instead the EKF will see the “crazy” compass changes don’t agree with the internal IMU (gyros) and will stop using the compass. Only if the compass is moved slowly will the heading change (slowly).

If it’s possible to post a dataflash log around perhaps we can see why the EKF isn’t happy. It’s probably the GPS isn’t getting enough satellites but it could be something else.

Hello Randy,
excuse my late reply, I lie with fever in bed :frowning:
I think I found the error after I bought a new Here 2 GPS to test and received the same error.
I think that I had too few satellites.
How many satellites are the minimum for safe operation?
I had 9-11 satelites when I had the mistake.
I want to install the system in a small RC boat, I think the EKF is not so important as an aircraft , right? ,
I do not quite understand the documentation, which parameter can I set the sensitivity of the EKF down?
When I set FS_EKF_THRESH to 1.0, nothing changes.
Or turn off the EKF?

Thank you & Kind Regards from Germany
Daniel

@kkarl,

I think you’re right that it is simply not getting a good position from the GPS. Are you testing indoors by any chance? If “yes” then maybe take it outside and see if it does better (it probably will).

The minimum number of satellites is 6 but it’s not so much about the number of satellites as it is about the quality of the data. With a Here2 (or any other modern Ublox) it is quite easy to get about 18 satellites. 9 to 11 seems quite low.

@rmackay9
Yes, I have tested in the apartment and on the balcony.
Can you still answer my question about EKF sensitivity?
Or it is not advisable to reduce the sensitivity.
I want to prevent that I am at the lake and the boat does not work.

@kkarl
I also encounter the same problem. build a boat with using Pixhawk1 with ChibiOS,firmware 3.5 or 3.4. when i run the boat EKF will be red and the heading of boat will deviate seriously.
But,if i use firmware 3.1 , the boat will run perfectly.

When I run my boat I get a red EKF until the GPS acquires a good fix. I am however booting up on ground and not in the water. Your EKF that is red is the compass? Maybe is getting a lot of interference.

@qdxiatao I think that with the problem are the few satellites.
I can only test in about 10 days on the water.
I will inform you as soon as I have tested it.

Strange that it runs in the 3.1. I think the development has changed a lot at the EKF.

@David_Boulanger

Thank you for your Reply,
I think with the problem are the few satellites. I can only test in about 10 days on the water.
I will inform you as soon as I have tested it.

@kkarl
when i test the boat, GPS is very good. I do not know why firmware 3.4 and 3.5 are unstable. To verify it’s the firmware’s problem, i burned different firmware to assure the cause of the problem.

1 Like

It is possible that the EKF requires a better setup (i.e. reduced compass interference) than DCM (the estimation system used on older firmwares) and we’ve also added a lot more safety checks to stop things from going wrong. Sorry for the initial pain of upgrading but I suspect you’ll find that once you get it working, the newer versions perform better.

Any chance a dataflash log can be uploaded here?

Hello,

I am having the same problem, this time with a quadcopter. I consistently get a good GPS lock and have let the quad sit outside for some minutes after the initial power up and connection to MP but the EKF still stays red, preventing me from changing the flight mode to auto.

Any ideas?

Thanks, Wade

1 Like

Hello, topic bumped. Problem appear after upgrading to V4.0.3. I have the same problem for first few seconds after start. GPS is OK - HDOP ~0.75, 14-16 sats. What have I mentioned, in this period before error clear: in telemetry, alterror is almost -20, NKF3 IVD,IVE,IVN =0, NKF4 SV, OFN,OFE=0
NKF4.TS=19, 16 afterwards. after all these data returns to normal, copter can loiter, kep position.
I have an idea… if filter timeout 19 and then 16 mean that processor is overloaded?

Servers by jDrones