EKF Status red with ArduPlane V4.0.9

I have 2 completely different planes (also different FC: from Matek, Omnibus), both running ArduPlane V4.0.9. Beside running the same ArduPlane release, I can’t get rid of a red EKF Status on both of them:

Usually I have between 15 and 25 sats, but the red status doesn’t go away even after waiting 20 or more minutes.
I already did a complete accelerometer calibration multiple times. Compass is disabled.

Yesterday I was a bit impatient and did a manual override and had a wonderful maiden flight with one of the planes. But I wouldn’t like to do this again as I’m aware this could lead to serious issues.

Any hints or ideas?

You can safely ignore those two red messages (when on the ground) and takeoff anyway.

Please do not disable any arming checks!

Hmh, I’ve never had this problem on other planes and earlier Arduplane releases.
Also I don’t plan to always have a laptop with me on the field for manually overriding. Normally I’m arming my planes via a transmitter switch. Is there some parameter to skip that arming check?

Just for reference: Parameter ARMING_CHECK helped me to skip the check.

What the leader meant was to not fly with the ekf atatus red. Disabling arming checks does not help your issue.

You will be better off sorting out the issue behind the red ekf status rather than turning arming checks off.

Ok, but where could I start investigating this? I don’t have any clue right now.
Btw., HDOP is always below 1.0 .

Youre probably experienced than I but perhaps a log file would better help resolve the issue.

Also tey recalibeating the compass etc. Try a different gps module.

The ekf status shows some issues with gps related variables.

GPS is a brand new Matek SAM-M8Q in each of the planes. At least this would be something, what both planes have in common, too.
Here is a DataFlash Log from yesterdays flight.

I realized, the above log doesn’t contain the pre arm messages. So I just created a new log with parameter LOG_DISARMED set to 1: Logfile
Somehow, this log seem to contain some garbage after timestamp 19:00:00 - just ignore this part (it looks like my previous flight log).

Any help is still very appreciated!