Dual telemetry lagging

Hi folks

I’d like to set up a 4G telemetry via raspberry Pi for long range. It works perfect until i connect with another SIKradio telemetry to the AP. SIKradio is connected all time, problem accours when i hit connect button on the MP.

At this time the 4G telemetry starts lagging and turns into read only mode. Cannot change modes e.g.
As i see it, telemetry1 or serial1 has some priority overt telemetry2/serial2.

I’m familiar with UART communication at this level. Bauds are ok, protocoll is Mavlink 2 everywhere.
I checked this behaviour with two SIK radios, 868 and 433 mhz paralell. The problem is active in this case too.
I’m on Arduplane 4.0.9 and Cube black.

I found Jeff’s topic about something like this but his sulition didn’t work for me.

Thank you for your help.

did you changed the gcs id for the second gcs ?

NOP! Is there?
I go look after it!

Found the setting in Mission planner, Config/planner section. I will try it!

How did you go with this?

The tip of Eosbandi solved it. Try to dismatch the GCS id at Config/planner section.

SOLVED! Thank you for your tip!
Köszönöm szépen :wink: