Servers by jDrones

Dual-motor tailsitters

( research air) #402

if your next test does not work ,what I would try is to mount the controller and it’s mount on plywood and hard strap it to the battery to test if that mass stops the oscillations, then if that worked, try a ply plate across that center section,? looks like a lot of flex in the whole craft. I am using the same f/w and swinging motors around as well, and don’t have that problem

( research air) #403

live and learn, I was trying to enter hover mode by just switching modes,any way to set manual hover and auto hover the same

[quote=“tridge, post:401, topic:15302”]
So anything above 50% means to climb, and anything below 50% means to descend.
[/quote]so is( qm_thst_hover), a way to ajust the stick position ?so setting at 0.7 would move the stick to 50%?

(lorbass) #404

OK, will do it as recommended.

(lorbass) #405

Yes, or opposite.
50% Stick will produce 70% trottle:slight_smile:

(lorbass) #406

The FC mounted on the Battery, the system shakes like bevor. Only if held away of the wing it stops shaking.
And if touched slightly the battery, immediatly it starts again.
2 possible reasons:

  • the Pixracer is defective
  • the Firmware don’t work at least not for Pixracer.

3 possible ways:

  • to throw away the rubish and enjoy the summer with my copters
  • to replace pixracer with pixhawk (to check if pixracer is defective)
  • to flash the PX4 Stack wich support also Tailsitters (to check if APM does not mach pixracer for tailsitter)

Perhaps last way because less manual work…

( research air) #407

sorry to hear, you might be right ,want to try with less active board mount,? maybe to soft, or board direct to the battery?strange that it worked before, or maybe time to take a break ? are you thinking loose component or connection on the board?

(lorbass) #408

Thanks for your sympathy, I’m not used to loose.
Development is to find a way around if it the plan does not work.
I’m already on the way to PX4. But this system needs an airspeed sensor
which I have to connect.
Will report the result tomorow.:slight_smile: or :unamused:

( research air) #409

well that will tell you a lot, looking forward to your report

( research air) #410

Hi, in manual motors spin up normal, in stablize right motor the one that drops out, starts much later than flys right wing low, in hover mode, it might not start at all ,and the left will flip the craft, this is gray with pixhawk have got it to hover but just waiting for the r wing to drop and crash again, changed controllers x2 motorsx2 rewired all power wiring still n/g ??? any idea ?send logs?

(tridge) #411

yes please. Try to identify which log corresponds to the video you just posted.

(lorbass) #412

Next “shaking” report.:worried:
Also with the PX4 Stack the Wing shakes as bevor.
Has to do with the mass inertia of the Elevons compared with the whole wing.
When I fix the linkage closer to the center of the servo (less angle of elevons) the
shaking effect is fewer.
One of the elevon linkage disconnected, no shaking.
I made the elevons larger than original in order to reach better control in copter mode as somewhere
recommended and succesful realized here:

OK may be the mass of the fuselage is greater.
3 possible ways now.

  • To change the FC to Pixhawk
  • To test the smaller elevons (with less effect)
  • To install a counterbalance as used in the olden days for steam engins (weight moving up when elevon move down) May be, thats an argument for vectored tailsitter?
    Project steam engin: Balanced Elevons (instead of Computer compensated):wink:

Is there someone using a Pixracer for a Tailsitter?

( research air) #413

I have pixracer in illusion belly sitter ,[quote=“lorbass, post:412, topic:15302”]
When I fix the linkage closer to the center of the servo (less angle of elevons) the
shaking effect is fewer.

can the controller sensitvity be dialed way down? then ajusted up to a point before the oscillations? I have done that with my custom controllers, again, no loose componants or connections ?

(lorbass) #414

I don’t know how, I reduce Q_A_RAT_PIT_P to 0.1 with no effect.
Yes, I would say it should be solved by correct parameter setup.
This can happen with other Frameset to.

Will check it more thoroghly.

( research air) #415

dial down sounds like a Tridge question

(Mark Whitehorn) #416

I noticed that FW ACRO mode should be able to hold any attitude, including a nose-up hover. Has anyone tried that with a tailsitter?

(tridge) #417

As @tilt mentioned, he is using a pixracer, but I believe he has added some mass in the form of an aluminium plate below the pixracer. Adding mass to a flight controller is a common method of improving isolation, and it is often especially useful with very light controllers like the pixracer.

(tridge) #418

yes, you could reduce the gains. Rough rule of thumb is find the smallest gain that causes oscillation in flight, then halve it to give some margin.
I would suggest you add some mass to the flight controller though. A aluminium plate or some lead is good.

(tridge) #419

i think you’ll find it won’t work well, although I haven’t tried. The ACRO mode in FW is very simple - it needs a lot of work. The main thing we need to do is make it use the copter rate controllers, which are much more suitable for low speed acro than the fixed wing controllers.

( research air) #420

any luck on your end, or should I keep diggin

(tridge) #421

sorry RIck, I’ve been busy on another project. I’ll try and have a look later today