DSM binding on PixRacer problem - RC6/7

Just upgraded to Copter-RC6, was really happy about having a fix for DSM(8/2/X) binding.
(because I only have a 6ch receiver with a satellite, therefore i could only use max 8ch)
I have a Turnigy 9xr pro with a OrangeRX DSMX DSM2 Compatible 2.4Ghz Transmitter Module (V1.2).

I tried to bind several times, but satellite did not turn to bind mode after pressing the bind, only blinked once.
But, it did turn to bind mode when transmitter was connected (led on). With it, the binding resulted in the same 8ch.

Therefore I tried to change the ID (by holding ID at RX startup).
After it cannot enable bind mode anymore, just flashes once, shortly.

I can still re-bind with the 6ch pwm spektrum receiver to get 8 ch on the satellite. (and I havent ever managed to get more than 8 ch from this satellite)

And let me say Thank You! for this new RC :slight_smile:

Is it an R12 or R14 Pixracer?

btw, 3.4-rc6 only got the first part of the DSM fixes for pixracer. Please test master (the ‘latest’ build) to get the full set of fixes

FYI AC3.4-rc7 (which will be out within 1 week) will include the 2nd set of patches that Tridge has mentioned above.

Good morning. Im not sure what revision is it. How can i check? Its a few months old.

Thanks, I will check on the master this evening.

Hi Marcell,

If this is the one you received from AUAV, it is an R14. R14 can be determine by looking on the PCB next to the SD Card socket. If you see the marking “RC14” then it is an R14 board.

@tridge - There was also that bug in Mission Planner that sent the wrong bind ID that resulted in only 3 pulses being sent. This might confuse a receiver expecting 9 or 10 pulses.

@tridge: I just finished testing the latest (from the fw server) with mixed results.

@pkocmoud Yes, it is the one received from AUAV, ordered at: 07/08/2016. cant check the PCB unless its essential, because its hard to access.
Updated my mission planner as well, from the current beta channel. Should that be ok?

DSM8 binding works just fine.
DSM2/DSMX just blinks once. tested many times.

Is that possible I have problems with my satellite? All satellites should work with all?

after I looked into the MP issue it was really just a difference of opinion of the interpretation of the mavlink msg. I changed ardupilot firmware to accept both interpretations. So it shouldn’t need a MP update if using master

Well, then I’m out of options.
I’m assuming my satellite is a crap and does not support anything other than DSM(8).
Can you please suggest me a DSMX satellite receiver? I’m fine with a PPM or other kind of receivers, but i would like to keep my transmitter module. Therefore it needs to support DSM2 or DSMX. I had bad experience with cheap PPM receivers, as their values aren’t stable enough.
So is there a cheap DSM compatible, spektrum-like receiver? I would like to have a lot of channels to use. : )
150-200m range is enough for my small quad…

I got the new DSMX satellite receiver today, upgraded my quad to RC7, and test.
It works, but only once of 10 tries. (binding does not start, just blinks once.)
Once it gets the signal correctly, binding is ok.

This receiver is really dsmx, my transmitter module blinks as dsmx 22ms. Although I set up 12 channels, I cannot use more than 9 for some reason. (I m already happy with the results, as i had 7 ch before).

Do you maybe have any idea? Thanks.

Unfortunately I don’t have a new enough Pixracer to reproduce this issue - the one I have has a hw bug that prevents DSM binding. Philip is going to send me a new one soon.

Can you please drive me to the location in the code where the pixracer dsm binding is? I would be happy to play around and maybe to fix this.

This problem still persist.
I’ve probed RC channel, no pulse train happened.
Under same hardware, I can see PX4 generates proper pulse to make receiver enter into bind mode.

I tested on ChibiOS, it works. But, it doesn’t work with ardupilot.