DShot600 ESC/Motor Setup help please?

Thanks Dave,
Link to Full Parameter List file is here

It was originally at 0.
Changed it to 1 to see if that would work and it did not.
So, now I changed it back to 0.
Same result.

Other than use of a safety switch I don’t see anything that sticks out. I would imagine you tested it but same result if it’s disabled?

Thankyou for taking a look Dave. I appreciate it.
I believe you’re speaking of what I call the Arming Switch (Arm/Disarm) on Channel 5.

I have not disabled it to give it a try (yet).

I’ll give it a shot tomorrow. I’m also going to look at disabling pre-arm checks (if any) as a trouble-shooting mechanism. Not clear how they might be interfering with connection to BLHeli32 configurator though.

Only other two things I can think of besides above are re-flashing the Arducopter 4.1 firmware to the flight controller and starting from scratch, and try another ESC.

I’ll keep working on it until I get it. Whenever I do, I’ll let all know the solution that resolved it.
If anyone has any other ideas, I’m always open to listening!
Thanks again!

Yes, sorry Tom I misspoke. Use of an Arm switch is not uncommon so I don’t suppose that’s related.

You know sometimes it’s hard to see the forest from the trees. You don’t have a FRAME_CLASS defined and there are no assigned motor outputs…

1 Like

I had a similar issue with Plane here:

If Copter uses a SCHED_LOOP_RATE of 400, maybe try setting SERVO_DSHOT_RATE to 5, which would give you an output rate of 2kHz.

You could also try setting SERVO_BLH_OTYPE to 6 to set motor outputs to DSHOT600 even if they’re not identified by the automatic motor mapping.

That will be the problem!!

I just flashed from plane to copter and got a frame type error when powering up. Don’t recall that. I just clicked on the quad frame one more time and it worked fine

When firmware is flashed for the 1st time FRAME_CLASS is unassigned and you will get a Frame: UNSUPPORTED message.

It’s also the reason some people complain that the full parameter list is missing some descriptions. Select a FRAME_CLASS, reboot and they magically appear…

1 Like

Thanks Dave, that’s interesting.
I did have the frame class & type set, however, I did that using a different (latest) version of Mission Planner.
I was having difficulties with that version. so I switched to the 1.3.74.
Perhaps when I switched versions and made changes to other parameters then “wrote parameters,” since i had not set it up with ver 1.3.74 MP it over-wrote what I have previously setup on the other version?
I had not setup any SERVOx_FUNCTION (motor outputs?) because I had SERVO_BLH_AUTO =1. I thought that setting was supposed to map the motors automatically when using BLHeli32 ESC.
In any case, I have now verified the frame class and type (Quad, H) are setup and I’ve got the Servo Outputs mapped as in the image below. This mapping is for a “reverse spin direction” motor setup from that of a “normal X configuration.”
Having verified frame class & type and servo outputs AND changing ARMING_CHECK=0 (disable al), I am still getting the same results as before. Nothing has changed. I’ll be working on this all day today to get it right!

You should have 1.3.75 and then load the latest Beta version from the button on the Help screen. Get in the habit of updating to the latest Beta often.

I started with “Latest version of Mission Planner” per AP site.
Drop-down menus in Setup were not appearing.
Researched that problem. Said to load Beta version (as you state). Did that. Drop-down menus still did not appear.
Researched more. Found online a recommendation to solve this issue was to try the previous version (1.3.74), so I did.
Drop down menus and everything else work on 1.3.74.

This is likely because of your configuration not the version of MP. I load the Beta version everyday. Today the option to select the version of firmware for the simulator appeared (cool). Greyed out dialog boxes, pull down menu’s not working, missing parameters; all often solved by a Beta update.

OK, re-opened 1.375 and connected. Drop down menus are now appearing .
Checked frame class, type and Servo outputs. All are saved as with 1.3.74 setup.
Now downloading latest Beta
Motor test still not working

BTW-A reboot/power cycle is required if Outputs, and some other things are changed.

Beta version (see image).
Everything seems to be working properly with settings same as I had with previous MP version.
Motor test still not working. Rebooting often

1 Like

Hey Dave, you’re not gonna believe this.
Progress! 3 of the 4 motors are now spinning in motor test! Short video clip here . AND, I’m now able to connect to BLHeli32 Configurator (image below showing ESC2 “bad” perhaps).
I’m gonna take this as a “Major victory!” Thank you SO much for your time & suggestions!
I have no idea what’s changed, perhaps the Beta version?
In any case, now I can start working on trouble-shooting just one motor/ESC.
I have an extra motor & ESC laying around if needed (always try to have spares)
Thank you again Dave! Very much appreciated!

1 Like

32.4 is pretty old. You may find things improve once you have updated to 32.8

1 Like

@andyp1per @dkemxr
loose wire in JST connector caused ESC2 issue
All ESCs updated to 32.8
Now working on correct motor mapping and spin direction.
Making progress thanks to Dave’s and your help.
Thank you!

1 Like

Tom great it is solved now,question for you Dave or Andy have you tried with different PWM frequencies and what was the results,many thanks