Drone wobbles on landing

I have a large 20in quad that bobbles on landing. I tried lowering the land speed min as other people with similar issues suggested. It helped a bit, but I currently have it down at 25cm/s and it’s still bobbling. Any other things I can try? (It has a rangefinder but it bobbles with it on or off)

Any help would be appreciated!

Also, I am using version 4.15

Update to 4.3.2 (latest Stable) and try again. Then if there are still issues post in the 4.3 thread and include a link to .bin log file.

We have several custom components that can only run on 4.15. So we have to stay, sadly…

This post was flagged by the community and is temporarily hidden.

Post a link to a .bin log file then but this should be in the 4.1 thread.

Moved it over.

1 Like

sorry, new to this forum

1 Like

Got another log? There isn’t much going on in this one but what’s there looks bad:

Oscillating motor outputs:


Oscillating Throttle output:

You can set this to 2X MOT_THST_HOVER
PSC_ACCZ_I

MOT_SPIN_ARM and MIN look kind of high.
What’s the idea behind MOT_SLEW_DN/UP_TIME at .25?
The Gyro filter at 10Hz is too low.

Note: If you can post a log directly here chances are it won’t contain much other than extracting the parameter file from it.

What would you suggest increasing the gyro filter to? Also, out of curiosity, what is indicating a low PSC_ACCZ_I and MOT_THST_HOVER?

The default of 20Hz should be right for 12S and 26" props.
PSC_ACCZ_P should be at MOT_THST_HOVER which you have. I should be 2X that. Perhaps it’s causing some surging in Z.

But looking at log …16.bin I think you should back up to basic tuning including the Dynamic notch filter.

sure does cause motor surging at times, as does using excessive psc accz D

Does PSC VEL Z, which is all over the place, have any impact on a smooth landing?

Appreciate the help, I will give this a try.

Would I be able to direct message you by text or email?

Thanks

I think you will find more help by staying here.

This post was flagged by the community and is temporarily hidden.

OK, I see. So you Auto Tuned this with aggression at .05? Not sure that was the best plan.

Tuning is the big problem. The attitude control is quite sloppy and with serious oscillations in the motor outputs the flight controller is having trouble getting down on the deck smoothly. And similarly it looks like there is oscillation in attitude control before you even lift off.
How is the stiffness of the frame, and is the landing gear quite rigid and not wobbly?

Start by changing these as a matter of course
ARMING_CHECK,1
ATC_THR_MIX_MAN,0.5
EK3_IMU_MASK,7
EK3_PRIMARY,1
FENCE_ENABLE,1 ← anything bigger than a racing qaud should use this
INS_GYRO_FILTER,20

The EK3 settings suit your flight controller and are the new defaults.
You have nice low vibrations so there should be no need to go as low as 10 on the Gyro filter.

I would “rationalize” the BATT settings, since one sensor is not doing current, and the other is. And they are both giving different voltage readings. Check and calibrate…
Set the same battery voltage levels and failsafe actions for BATT2 as you get for BATT after the Initial Parameters bit below

Next, I would set up the Harmonic Notch Filter as follows
INS_LOG_BAT_MASK,1
INS_LOG_BAT_OPT,0
INS_HNTCH_ENABLE,1 ← set this then refresh params to see the rest
INS_HNTCH_MODE,1
INS_HNTCH_REF,0.222
INS_HNTCH_FREQ,30
INS_HNTCH_BW,15
INS_HNTCH_ATT,40

Now connect to MissionPlanner, Mandatory Hardware, Initial Parameters
Put in your prop size and battery cell count.
Select the Suggested settings too, but no need for you to pick the T-Motor Alpha settings (you already have them)
Accept the FLT and battery voltage related parameter changes, deselect the ACCEL values (you already have them)

I would be tempted to try a test flight in AltHold with these PIDs
ATC_RAT_RLL_P,0.1
ATC_RAT_RLL_I,0.1
ATC_RAT_RLL_D,0.00625
ATC_RAT_PIT_P,0.1
ATC_RAT_PIT_I,0.1
ATC_RAT_PIT_D,0.00625
If there’s oscillations (worse than usual) land immediately and put those PIDs back to how they were.
If takeoff is OK, just hover for a while and do some gentle pitch and roll.
Then post a link to that log.

If you can get a bit better stability/attitude control you could run Autotune and get this behaving quite well.

FYI:
I understand a lot of larger craft came pre-configured and “tuned” from some suppliers, and I still cant tell how they ever worked properly or flew with any stability - I’ve spent the last couple of years searching for a manufacturers tune that is anything like stable.
I suspect the early T-Motor Flame ESCs have quite poor firmware and maybe new ones (or a firmware update) would do better. If you ever have to pull out the ESCs for any reason, there’s better alternatives.
I’m assuming you have T-Motor Flame ESCs…

From above, looks like he is using “Alpha 60a HV ESC 12s system, U8II 100kv FM2614 propeller.”

We adjusted the notch filters, it did seem to make the drone fly a bit smoother in the air. However, it did not fix the landing issue. We also increased the gyro filter from 10 Hz to 20Hz with not a noticeable difference. Next on the docket is mot_thst_hover and psc_accz_I. Any other suggestions would be great.

After review of some of those logs I wouldn’t place the landing issues as the priority. Basic tuning is poor so I would back way up to the Pre-tune condition (After Initial Parameter Setup) and start over. The Rate PID’s Shawn suggested look like a good place to start.
The goal would be to properly configure the notch filter and run an Auto Tune with Aggression at default. Obviously monitor the logs along the way to look for Oscillation (Rcouts and Rate) and if present deal with that manually as Auto Tune will fail if present.

No one thing is going to fix it yet - all the things Dave and I mentioned should be done leading up to an Autotune.

EDIT: the video answered a couple of my questions - the frame and landing gear looks nice and stiff.

And keep the giro filter at 10Hz