Drone tilts and moves to North-East direction during takeoff

Hi, I have recently assembled a new drone on the F450 frame. When I try to fly it, it always tilts and moves towards the north-east direction during takeoff.

I have tried looking at the logs but honestly don’t understand much there. I have observed one motor - motor-A (number 1 CCW) a bit slower than the others. But I believe the drone would know that its tilting towards that direction and try to speed up that motor to balance itself. The drone is in Stabilize mode.

Please find the logs here: ardupilot-log - Google Drive

Kindly suggest.


I had a similar problem. I found one of my arms was not tightened down correctly. Once I fixed that everything was good.

You may want to try position hold mode and see if it corrects itself.

I recommend to level the “prop disc” across the top of the motors → side to side, diagonals, front to back…
Pack under the landing gear to achieve the best level possible.
Don’t assume whatever you are resting the quad on is level, or that your frame and landing gear is all perfectly equal and symmetrical.

Then in MissionPlanner , Setup, Mandatory Hardware, Accel Calibration press Calibrate Level


I doubt that would help as there is seemingly no Compass or GPS. Which Position Hold requires.

There’s something strange going on with altitude too - are you holding it??
Throttle rises sharply for a brief time, but altitude does a smooth curve over a (relatively) long time

No, not holding it. The copter is placed on a level ground:

  • I arm the copter.
  • Slowly raise the throttle until there is enough thrust for a liftoff.
  • The copter glides across the floor while dragging the north-east arm with the ground and hits the wall.
  • I disarm the copter.

I will record the the event and share the vid and updated logs for it shortly.


Hi, pls find the video of the drone flight and the latest logs below:

video: https://drive.google.com/file/d/175mR4dINXZo1nROKqwvL9lwduZtchv-L/view?usp=sharing
logs: https://drive.google.com/file/d/14ncRxhKdTA795eA3ABH3rdz2HIgwIIio/view?usp=sharing


Perhaps it doesn’t have enough thrust to take off. The motor outputs are at max and it’s still on the ground.

Describe the components of this craft (motors, props, battery power) and it’s take-off-weight with battery. Those are some small props for a 450 size quad.

It has the power to takeoff. If i pull on the roll stick and fight with the controls, I am able to make it take off.
I have also tried with a larger set of props - 1045(10 × 4.5), the behaviour is the same.

FC: Omnibus F4 V2 pro
Motors - A2212 1000KV
ECS - Simonk 30A, PWM protocol
Props: 5045 (5 x 4.5)
Battery: Orange | 1500mah, 4 cell, 14.8V 100C


Those props are much too small. You should be using a 9 or 10.

1st, replace those 5045 props. They are not suited to 1000kV motors. If that craft weighed more than 350g it would be grossly underpowered with those props. And I’m sure it weighs a lot more than that.

Then perform another accelerometer calibration. Where is the compass/GPS?

BTW-Those motors are not well suited for multirotor use. They typically come in the very cheapest kits with junk ESC’s. Collet prop adapters do not belong on a multirotor.

Something like this I suppose?

Yes thats exactly the kit I am using :sweat_smile:. I was thinking of this as a copter where I wont have to worry about damaged motor/prop and could ealisy replace them.

Where is the GPS? I have lost 2 gps units on this drone. This 1st one stopped responding and started heating up and the 2nd unit sends garbled output to the serial monitor. I have bought a 3rd unit but I wanted to get this drone stabilized before using it. I hope that works.

I will upgrade the props, try the same steps and share the vid and logs.

Thanks for your support :innocent:

Well, you should get some decent motors and ESC’s. The rule with those ESC’s is buy 6 to get 4 that work.
You need a compass in any case.
What serial monitor? If you are talking about Terminal in Mission Planner you can expect garbled output whether the sensors are working or not.

Hi, yup thats how I bought the stuff. I have extra ESCs and motors.

I have observerved that one of the motors is slow no matter on which arm I attach it to.
I can replace that motor, but I wanted to understand the done’s behaviour before I do. My expectation is that the drone would identify that the drone is tilting to one side and attempt to corrrect this.

Can you help me understand why we need the GPS. can’t the drone stabilize without the gps?

And regarding the GPS output, I was expecting a clean output like in GPS Module with Arduino- Ublox NEO-6M - YouTube


You don’t need GPS for some flight modes (Stabilize, Acro) but you do for all others. And a compass is required except for some advanced configurations. I don’t see how that YouTube video is relevant. Get an M8N GPS/compass module and connect it.

Hi, I re-installed the larger propellors - 1045(10 × 4.5) and this time the drone flew flawlessly. It was so releaving to watch in fly.

I would not have guessed the prop size had this effect. With small props, the thrust was less and since the motor was on max output (based on the logs), there was nothing more it could have done to speed up and balance itself.

Next I am trying to get the GPS/compass working on it.

Thanks a lot for helping out.