Drone struggles to liftoff / motor burned


The drone description is a quadcopter with an X configuration with these specs:

  • approx weight (with battery): 1.5kg
  • battery: 6S 5000mah
  • ESC: T-Motor F55A Pro II
  • motors: T-motor f90 1500kv
  • Power monitor: power brick mini for pixhawk cube (not calibrated with amperage measurement)
  • Propellers: 5.1’’

I’m attaching 2 logs

The first log is the one where one of the motors burned during the takeoff procedure. The drone didn’t lift off. Do you see anything abnormal?

I don’t particularly like:

  • Fast rate of RCOUT and the peaks at 2000us
  • the acceleration at Y axis

The second log is from a previous day when the drone lifted off normally and we had a short flight just to see its attitude.

In both cases, we also noticed that the capacitor (470uF, 63V) that we weld at the ESC pins (the pins that the battery connects to) has one of its legs melted/burned and cut.

Logs: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free (size was too big for these bin files)

The battery voltage is only showing 17V, yet you’ve mentioned you’ve got a 6s battery.
Has the calibration for the PM been done ?
If not any readings in the log relating to voltage and current are somewhat useless.
But it does show that current went suddenly up by about 5 times.

Can you please indicate where are you seeing 17V? I may have missed something.

Bellow are the two BAT.Volt fields from the 2 log files, showing reasonable values.

Sorry, my bad.
Been looking at to many logs lately. This was a log from someone else.

My original thought was that the combination of motors and prop size you’ve got is wrong for a 6s setup.
Looking at the correct .bin file this appears to be confirmed as there is very high current flow.
But given that you’ve mentioned you didn’t perform a PM calibration I can’t comment any further as I don’t know how reliable that data is.

The motor outputs are wildly oscillating hence the torched motor. Drop the rate P&I values in half to start and see if you can get a relatively stable hover. Need to know the thrust hover value to set the appropriate PSC parameters next.

Why are you not using Dhot? And specifically the Bdshot firmware. I have that same ESC on a 7" on 6S with 1300kV motors.

Yes, that current spike is a bit worrying.

At the next test flight we will:

  • Calibrate the PM or use another one calibrated (MAUCH PL)
  • Use a 5s battery, just in case.

Thanks for checking the log.

We will add the reduction of P & I values to our checklist for the next test flight.

We are not using Dhot/Bdshot since we are not very familiar with these ESC protocols and usages/configurations. Although it is something that we will investigate in the future, after solving the main issue of the burning motors.

The next step after getting stable flight will be to configure the Dynamic Notch filter and you will want ESC telemetry or bi-directional Dhsot for that. Sticking with PWM now will just cause backtracking later. This are fundamentally initial configurations.

UPDATE 03/10/2022

So the changes that we did to our quadcopter:

  • Lowered the P and I terms at both roll and pitch (from 0.135 → 0.07)
  • Used a 5S - 3300mah battery (we had previously used a 6S)

The copter took off without oscillations and climb to about 2 meters. A brief hover of 1-2 secs followed.
The pilot noticed that the throttle response is a bit laggy. It does not climb/descend at the rate he commands it to do.

You can check the log: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free
Our next move will be to try again to have a stable hover and fix some issues with the frame and try AltHold. What would you suggest as next steps?

Note: the copter flies indoor for now without GPS utilization.

1st find another Cloud service for logs. WeTransfer is terrible.

I don’t see that, they are at .10 and still too high because there is still oscillation in the outputs. Look for yourself I showed you how in the image above.
You need to hover for more than a few seconds. 30 seconds or more.
You didn’t set INS_LOG_BAT_MASK to 1 to log data for the Notch filter.

It’s not a good idea to switch to AltHold inside until you have established a MOT_THST_HOVER value.

I believe that it is the correct log. I can see:

Either way, here it is uploaded to google drive: https://drive.google.com/file/d/1K09KV32Evdaun-DYbdbXyTsiGsJSxIvu/view?usp=sharing

Ok, so the next thing is to hover for ~30secs and then check the logs again.
We will also enable the INS_LOG_BAT_MASK in order to check the filter.

I don’t know where you are getting that. The parameters extracted from the log file you posted show this:



The problem was solved by lowering the D terms (both for Roll and Pitch). The term right now is around 0.0002. Anything above that led to motor overheating, and abnormal attitude.
We performed the tuning with a 5S battery so the next step is to try 6S and re-do the whole tuning process.

You can see at this log how lowering the D value changed how the RCOUT looks: https://drive.google.com/file/d/1p2H-92aG0E9g8kCdQ5Fg-d9ByWIMcVgp/view?usp=sharing

We tried the AltHold flight mode but the quad was drifting upwards. Maybe it was the presence of mild wind. Although we were using AltHold for quite 20-30secs it did not alter the MOT_THS_HOVER parameter. You can check the log here : https://drive.google.com/file/d/1UU86-2hFJVWNNN4DVqdoWui2IODxLtAZ/view?usp=sharing

We changed manually the MOT_THS_HOVER to 0.36 by tracking the ThO value.

The next step will be to setup the Notch Filter and try Loiter mode. Following, we will try AutoTune or Quicktune.

Nothing to see in the 1st log accept oscillating outputs and massive vibration levels. The 2nd log is corrupt.
A D-term that low is not the solution to the problem. The rate Pitch and Roll P terms are still high so you are making no progress. Read the posts above.

Lowering the P&I values only made no difference. Next time that we are gonna try the 6S battery we are going to follow the guidelines of Initial Tuning (reducing everything by 50% etc)

Massive vibrations? This is the last part of the log (when D term was at its lowest). I don’t see anything terribly bad (except from the landing vibration)

The log that was corrupted (where Althold was attempted): https://drive.google.com/file/d/1UcZRoMOpNKUzk0XwFL6t68bREeEOYYcz/view?usp=sharing

I would reset to default and start over with the Initial parameter setup. Set the Rate P&I values to .07 and after establishing the Hover thrust value set the PSC parameters.


We restarted the procedure with a 6S battery. We found some values that seem to work out fine so we headed out to try AltHold after configuring the Hover thrust.

Althold seemed to work relatively fine and tried Loiter also in which the drone flew really well and was easily controlled.

We then proceeded to log the IMU data and set the Harmonic Filters. Although there are some strange results. Below you can find an image of the accelerometers and gyro results. The amplitude is on the negative side. Can this be caused by the configuration of our quad? (X configuration and propellers are on the low side - motors are facing the ground). Also here is the log: https://drive.google.com/file/d/1ljy_uzUqvcymkZf7UV1KBX-Hc3Rj8rjW/view?usp=sharing


It seems that the above results (negative amplitude) was a bug(?) with mission planner on my laptop. Tried to open it on another PC and it worked.

Used the image below to set a HNF at 119Hz.

It’s not a bug it’s a feature. The 2nd PC probably had an older version of Mission Planner. In any case a log scale, which is what’s shows in your 1st post, is default. There is a “Magnitude” checkbox to change that.