Drone sinks when put into Auto mode

Pixhawk PX4 Firmware Version V3.5.0-rc8
s500 Drone kit
I have done many autonomous flights before with good success but today I went out to test a new extension arm I added (to get sensors out of the wake of the propellers) and it seems that the added weight is causing the drone to sink when put into auto mode. I offset the battery and the CG is level. Either that or it is doing a failsafe landing for some reason but I checked the log and there isn’t any errors that I can see. I tried putting the drone in auto mode 5 different times and same problem each time. It flys fine in stabilize and GPS hold. I have also had MANY compass issues in the past, and still get some occasionally (Error compass variance, compass yaw spinning/drifting). Anyone experience this issue before?20170704161125.bin (2.7 MB)

I have not looked at the logs yet but I strongly suspect it’s because the altitudes are expressed as “absolute” rather than “relative”. If you’re using the mission planner, there’s a drop-down just above the command list on the flight plan screen. There was an issue with the mission planner a month (or more) ago where it kept setting that drop-down to absolute. recent versions of the MP don’t have the problem though.

That seems to have been the problem, going to fly later today so hopefully that fixed it. Appreciate the help!

1 Like

Okay went out and did another auto flight. It started fine and got through 2 waypoints before sinking again…weird right? Is the relative altitude set per waypoint? Also I found this elevation graph that might be of use (however it doesn’t explain why the drone today made it through two waypoints before sinking down2017-07-06 19-33-55.bin (2.3 MB)


Relative altitude is based on take off altitude and will be the same at each waypoint unless you check verify height. When verify height is checked, mission planner uses SRTM data to set default height above the terrain elevation at that waypoint. It’s a really nice feature of mission planner