Drone not accepting commands

I have an SDR Solo loaded with OpenSolo 4.0 which I believe is an Ardupilot version

I can receive messages from my drone and decode them but it does not respond to messages I send using the mavlink c header files. I have posted this problem on the mavlink forum thinking it is a mavlink issue but a post I read over there suggested that it might be a Ardupilot specific issue.

I modified one of the mavlink examples to create a windows test tool which I posted on github at GitHub - bclay1297/MavTest: Windows /Visual Studio version of the mavlink c_uart_interface_example

It would be great if any window users would download the test tool run it and let me know the results. It is not a polished tool (yet) but it seems to work other than no change in the drone status. I compared the basic message structure to that created by QGroundControl and it seems to be the same. I have not found examples on setting the ck and signature parts of the message structure but I took a quick stab at setting them. Is there a specific sequence required by Ardupilot for starting?


Update to Open Solo 4.3.7 and retest.

The problem was a version issue. The Arducopter that was loaded with the OpenSolo firmware update is using mavlink v1… I was using mavlink v2. While I could receive and decode the messages the drone was rejecting everything I send because it had the 0xfd magic number and the drone expected 0xfe

The issues that were fixed according to the readme did not include upgrading to V2

Do you know if there is a plan to upgrade?


OpenSolo 4.3.7 Supports mavlink 2

Unfortunately when I tried to upgrade to the 4.3.7 using solex, I get the message “Package is not compatible with this vehicle” I got the same message when I tried to load 4.0.3.

My solo is a stock / original Solo which I think I read somewhere is a pixhawk 2

Is it a 1M cube green? AFAIK only cubes either green or black are built in original solos. No pixhawk 2.4.8

Find if it is a 1M or a 2M board and install the according version of 4.3.7 on it.

I pulled the camera off and could see a black cube but the upgrade website has stock, green and orange zip files not black

Stock is the black one. The question is why it is refusing the firmware update?

Thanks for your help. I walked through the process again and it seemed to do all of the steps but when I restart the system the controller still shows OpenSolo 4.0 and the “magic number” or sync byte still shows up as 0xfe instead of the 0xfd as expected.

How can I tell if it actually did the upgrade?