Servers by jDrones

Drone is not taking off in guided mode

I am working in AC 3.2.1, and trying to use pymavlink library to send MAV command to the flight controller .

The apm is correctly listening to most of the command that include in
1)arm and disarm command
2)mode change command (guided,land)
3)streaming telemetry command

However ,apm fail to takeoff .

I tried to see on simulator using dronekit copter 3.2.1 and the takeoff commands works
I find an attachment which states that 3.2.1 can takeoff in guided mode

Can anyone know it what is the issue. One more thing I am building the 3.2.1 apm code on arduino-ardpilot software and uploading it.

Thanks in advance
Samarth

Do you have GPS signal ? without it it will refuse to takeoff.

Yes
I kept it in guided mode and then arm the motors
My motor started to spin at a very low pwm level

The motor can only be armed when there is 3D fix so I don’t see it that there is gps problem
The telemetry data verifies me that it is in guided mode

Does 3.2.1 supports takeoff command in apm 2.8 , as takeoff command easily work in above AC 3.3 with pixhawk fight controller?

Hello
I have done some more testing regarding the same problem.

When I used dronekit , the drone in apm 3.2.1 was able to takeoff in guided mode.
But when directly using pymavlink , All command under guided mode did not work .

Can anyone tell what special is in dronekit platform as dronekit import pymavlink library and use the same command to takeoff which I am trying directly with pymavlink.

Thanking you
Samarth

Hi @samarth_kapila, I am facing the same issue as well. my motors started spinning upon arm but stopped the moment it stated takes off. Have you found the solution?

Hello brit000
My problem is solved when i set system ID and command ID to 1. One more thing, i was working on APM which is obsolete now. So the problem never occur to be in pixhawk and upper firmware version

Hi everyone, I started building an hexacopter (flame f550) using a raspberry 4 and the orange cube with optical flow and a leddar One. I have installed mavros. I’m trying to get the raspberry to communicate with the cube. I can see the topics and read what they publish. But I have these problems:

  1. At the beginning i couldn 't see the eco of the topics so i use this line “rosservice call /mavros/set_stream_rate 0 10 1”( is it correct?)
    but i can’t see the eco of local_position/pose. Do you know why or how i could solve this problem?
  2. my second problem is that the copter could not take off. I switched the mode in guided and arm the copter then I tried to publish a velocity with “mavros/setpoint_velocity/cmd_vel_unstamped” but the copter didn’t listen to me. So i tried to use “mavros/setpoint_position/local” but nothing. i think that for now i can’t use setpoint_position because i don’t have an echo from local position.
    My question is :
    what am I doing wrong?
Servers by jDrones