Drone is experiencing a z-axis oscillation while hovering

Hi all,

I just started noticing a vertical oscillation on a drone and am unsure what the cause is. All vibes seem to be pretty reasonable, and I’ve tried adjusting PSC_POSZ_P and PSC_VELZ terms but they don’t seem to be making any difference. Any thoughts on what else I could look at? Log is attached as well as a screenshot of the altitude. The drone flies fine, it’s just when I takeoff or return to a hover that it starts this steady state oscillation.

Thanks in advance!


How did you come up with those Rate PID’s?

And you don’t want EK2 active. Set those PSC parameters back to default. You probably only have to change these based on the Tuning guide and MOT_THST_HOVER

What size props on this Tri? Some of the initial tuning parameters don’t look set.

Thanks for the response Dave.

The rate PIDs were all manually tuned.

It’s running 18 inch props. I have since gone back to defaults for all PSC parameters. It’s weird because this drone has dozens of flight hours on it, and I haven’t noticed any oscillations of this magnitude until yesterday.

What other initial parameters do you see that aren’t set?


There is no precedent really for the ratio of P&I values you have. They are typically equal or in some particular cases I is a “bit” lower. The D-term for Pitch looks high.

The ones that are produced from the Initial Parameters Setup in Mission Planners Mandatory Hardware section. Run it and see.

I think I would do the following (somewhat of a reset):
Disable EK2
Update to latest Stable
Set the rate D=terms back to default and the P&I terms to 0.1
Configure as per the Initial Setup Parameters as mentioned.
Setup to configure the Dynamic Notch Filter:
Configure the Dynamic Filter as per the Wiki. Either Throttle based or FFT.
Run Auto Tune.

1 Like