Drone Hobbyist trying to solve Toilet Bowl Issues! Plz help

I use the Pixhawk 2.4.8. I find it a great FMU for my homemade drone I’m building. The only problem is … toilet bowling in position mode.

Here is a list of all the things I’ve done to try to solve the toilet bowling:

  • Started flying in an open field
  • Re-Calibrated the compass many times
  • Shielded the External Compass from possible interference using RF tape
  • Enabled GPS_Dump_Comm in the Parameters to read the data, GPA data seems consistent, maybe compass issue???
  • Tried to link the distance of the GPS to the FMU in the parameters by marking EKF2_GND_EFF_DZ to 13.1ft, EKF2_GPS_POS_X&Z to fit drone
  • Pressed the reset buttons on the FMU
  • I’ve even used an electronic can or air on the FMU to blow out any possible dust
  • Swapped the FMU a couple of times
  • Tried to disable the FMU Compass using Cal_MAGx_PRIO

I’m starting to run out of ideas. Any ideas would be greatly appreciated. :slight_smile:

Did you use ALT-A on mission Planner?

Did you set up the dynamic notch filter?

Post a link to .bin flight log is an idea.

Not yet, let me try it out!

The dynamic notch filter is currently disabled as the frequency is 0. Bandwidth is set to 20 Hz by default, any advice on tunning?

Sure. I advise you to read the documentation and tune it properly.

1 Like

Not sure what you are looking at. When the Dynamic Notch Filter parameter is enabled the default frequency is 80Hz.

@justryingmybesthere Make sure the external compass is set to be the first compass, then disable the on board (compass#2) compass with COMPASS_USE2: 0

This isn’t completely intuitive as one might think it would be labled “COMPASS2_USE” but so it is

I have several pixhawks and the on board compass has too much interference to be helpful, and most of the time confuses the software (and causes toilet bowl).

Wow - this is great advice! I’m searching through the Parameters on QGC but having no luck finding it. Could it have a diffrent title?

It’s there but you would be better off to use Mission Planners Compass screen and re-prioritize and/or delete the compass’s