Drone goes down in Stable mode, when I move right

Dear Experts,

I am newbie in Drone word, please help understand what is going on.
So I created drone based on pixhawk, drone seems can keep its height if I dont move it.
But when I move the drone left or right it starts to go down. Please see here:

Even if I do trottle, still drone does not going up.

Can someone please help understand what is going on.

You need to download the .bin file from your flight controller and post it here so we can see what’s happening.

Thank you Mike for the info. Please see the bin files attached.

I am sorry I dont have enought knowledge to understand the log files((

If you can help, that would be really great!!!

2019-12-01 10-04-17.bin (276 KB) 2019-12-01 10-11-05.bin (107.0 KB) 2019-12-01 10-12-27.bin (247.3 KB)

I do log analyse, and these are failing:

Test: Event/Failsafe = FAIL - ERR found: FS_BATT 
Test: NaNs = FAIL - Found NaN in CTUN.DSAlt
Test: OpticalFlow = FAIL - FAIL: no optical flow data
Test: Parameters = FAIL - 'THR_MIN' not found

Are these dangerous?
May be I should study what these fields mean, but if someone can explain that would save lots of time for me~

Full analyse result:

Log File C:\Users\usr\AppData\Local\Temp\tmpC13D.tmp.log
Size (kb) 472.658203125
No of lines 6421
Duration 0:00:15
Vehicletype ArduCopter
Firmware Version V3.6.10
Firmware Hash 1c04a91e
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD -
Test: Compass = GOOD - mag_field interference within limits (1.51%)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERR found: FS_BATT
Test: GPS = GOOD -
Test: IMU Mismatch = GOOD - (Mismatch: 0.38, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = GOOD - Motor channel averages = [1339, 1344, 1313, 1373]
Average motor output = 1342
Difference between min and max motor averages = 60
Test: NaNs = FAIL - Found NaN in CTUN.DSAlt

Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = FAIL - ‘THR_MIN’ not found
Test: PM = GOOD -
Test: Pitch/Roll = GOOD -
Test: Thrust = GOOD -
Test: VCC = UNKNOWN - No CURR log data

Can anyone please provide some help here~

You haven’t given us any details about your setup in particular battery and motor/prop combination.

From the logs I detect you are using a 2S battery.
That will not work as you are experiencing.

As soon as you ask for current the voltage drops too low and your battery failsafe kicks in.
You also loose the power to keep the copter stable.

Dear Mike,

Firs of all thank you much for your time.
I am using 2200mAh:35C Series battery. Just cheapest one~

Can you please teach me how you generate these waves please? I tried to generate such waves using Mission planner “Review Log”, but could not.
I would be very happy if you can provide some materials about how to fix my battery issue.

Thank you again~

I am sorry to bother you
can someone please answer~

I use APM Planner to do the log analysis.
Download link are in the Ardupilot Wiki.

You have still not given any details about your copter.

If you don’t provide the information requested then there is not much else we can help you with.

thank you soo much.
To be honest I just bought ready set from Aliexpress:

And there are the info
Motors: 2212 920KV
2212 920kv Motor

  • Type : 22 x 12mm
  • KV: 920rpm/V
  • Voltage: DC 7-12V
  • Weight: 53g

Props: 1045 propeller
30A simonk esc :

Size: 55x26x8mm (length 145mm including power cable)
Weight: ~24g

I know these parameters are important, but if you can please explain how you debug my issue using this parameters that would be excellent help!!

What they actually said was the Motors are 2S-3S.
They don’t state anywhere in the add that you need a 3S battery, which they should.
The 53gm is per motor.

You need a 3S battery.

This is a common configuration 920Kv motors w/10” props needs at least a 3S battery.