Drone flips after motor replacement

Hi @ all,

I’m flying with a PixHawk 2.1 on a F450 frame.
Before i had some DJI 2213 motors installed and it was airborne several times.
I wanted some more power so i changed the motors to T-Motors 2814-10 KV 770.
I calibrated the esc’s again with the new motors just to be sure…
Now when i want to fly the drone lifts and when it’s in the air it flips 180° into the
ground. I’m still very new to all this and i have no idea why it’s doing it.
I have attachted a log file maybe one of the pros can have a look on it ?
Maybe somebody can explain me where on the log file i can see whats wrong ?

Thanks in advance58 01.01.2000 01-06-24.bin (1.3 MB)

I think something is wrong in your RC, since there’re sudden change in both roll and pitch channels.


I couldn’t see much from the log - looks like you increase throttle a couple of times, each time a bit more until finally your drone tried to take off - when it flipped dramatically.

This could be a symptom on mechanical rotation direction issue (can happen easily when changing motors and getting the cables wrong) or incorrect propeller/motor direction alignment.

There is a separate thread on this here:

Maybe that helps,


If this is a new frame, it’s best to start with the official release rather than a beta. So best to go back to AC3.4.6. That separates issues related to the beta software from the regular setup issues that people sometimes struggle with as part of putting together a new frame.

I agree with Christian’s advice that it would be good to double check that the motor order and propeller direction are all correct.

Thanks to all for the help.

I have checked the wiring, the spin direction and the propellers for proper installation. It looks good to me…
The drone does not flip when i’m advancing power. It lifts for about 30 cm and the it does the flip…
I’m flying other drones with the same radio so i think this is not the problem…
@worm_earth Where did you see this inputs ?

Thanks in advance…

Sorry, are you using bullet connectors ?

@ambattuhari yes i’m using high quality 3.5 bullet connectors

From the RCIN C1 and C2.

I’d recommend re-doing the ESC calibration (http://ardupilot.org/copter/docs/esc-calibration.html) and use the MP’s motor test feature to make sure the deadzones at the bottom of the ESCs are not too big and that all the motors start at the same level which is above MOT_SPIN_ARM and MOT_THST_MIN.

Hi again,

Thanks to all for helping me.
@rmackay9 : I have done exactly that. I checked everything at least 5 times and still the copter want^s to flip.
I also went down on the Pixhawk firmware to 3.4.6 but since the i can not look at the Log files ( FMT message missing ) I also used the motor test feature to check again the wiring is correct ABCD all good.
I can not figure out what is wrong…

Maybe somebody else can open the log ???

11 01.01.1970 01-00-00.bin (0 Bytes)

The latest log is zero length I’m afraid so that’s why you’re seeing an error. Maybe you can find another?

I had a quick look at the older log and a few comments:

  • looks like the radio (aka transmitter, aka RC) calibration hasn’t been done
  • some of the arming checks have been turned off, turning these back on would be good to catch any problems
  • compassmot has been setup but really these days, it’s normally not necessary if using an external compass (which it looks like you are) so probably good to set COMPASS_MOTCT = 0.
  • software version is “AC3.5-dev” (aka “latest”) from a couple of months ago. better to use AC3.4.6 or worst case AC3.5.0-rc6.

I know you’ve already received some of this advice… sorry to be annoying.

Hi @ all

@rmackay9 : Thank you for you for helping me, it is not annoying at all !!
Radio calibration is done
Arming checks set
Compassmot set to = 0
AC 3.4.6 loaded

Tried to testflight it again and it still have the same behavior…
After 2 or 3 secounds of howering there is a flatter noise and it wants to flip…
Still not possible to have a look at the logs ( Bad Logging when it armes )
Sorry for all this but i have no clue whats wrong…

Did you do the motor test and make sure the props are all spinning the correct direction?
Then check your props to make sure they are not reversed.

Also make sure you have the correct frame selected.
But that would be discovered in your motor test.

The one and only time I had a copter do what you describe, I had selected octocopter instead of octoquad in the new frame setup of the latest MP beta
In a rush I did not check my motor spins and it did exactly what you said.
X8s make nice mowers when they are upside down

Hi again.

I had to format the sd card, now i can see the logs again !
@pyrate : i realy checked this now several times and i would agree when the copter would just flip
but it flys for 2 or 3 secounds and the its fliping…
@rmackay9 : Maybe you can see something on the log files ???

Thanks in advance…2 01.01.2000 05-14-24.bin (830.8 KB)
3 01.01.2000 05-17-44.bin (1.4 MB)

It looks like a problem with Motor4 (back-right). It displays the classic sign in which that motor goes high and it’s opposite, motor 3/front-right goes low. The same pattern happens in both logs.

Thanks for downgrading to AC3.4.6 which is also very well tested and stable so I think it’s safe to conclude this isn’t a software problem.

Hi, Try direct soldering on motor 4 and test fly.
Copied from troubleshooting, ardupilot.org
My copter flies well, but then dips a motor arm in a fidgety manner while hovering

The most likely cause of this is your bullet connectors. After your initial setup, when you test motor direction and electrical connections, westrongly recommend that you cut off the bullet connectors and directly solder the motors wires to the ESC wires. That way is vibration-proof and will lead to much more reliable operation.

If your wires are soldered without bullet connectors and you still see this issue, there are some other things that can cause this problem. Your motor may be going bad: either the bearings are going or your shaft is horribly bent. A motor with bad bearings takes more power to spin. In that situation, the ESC could be cutting out to protect itself. Or it maybe flying slow enough to stall the motor. Attach a current sensor between your battery and the motor and test the difference between a good motor and the bad one. If you are seeing higher draw in the bad one, replace or fix it.

Hi again.

Thank you @rmackay9 and @ambattuhari for helping me with this problem.
I have soldered all the conntacts now and tried to test fly but it still wants to flip.
I also interchanged motors and esc’s to see if the fault is staying but i still don’t
understand whats happening.
I have a log attachted maybe somebody will see something…

Thanks in advance

23 01.01.2000 01-13-14.bin (2.5 MB)

Maybe you should try althold mode? It looks like you’re bringing the throttle to zero in stabilize mode. If that is done, it stops stabilizing and will flip.

Hi again.

@rmackay9 : Thanks a lot for helping me !!!
In the graph you see me advancing the throttle everytime a little more until it wants to hover
and in the end i’m pressing the emergency power cut off switch so that the copter is not fliping…
Anyway i have found the fault. It was the ESC of motor number 4 that caused all that trouble.
I have replaced it and now it looks fine !

Thank you to all of you !!! I’m realy thankful for all the help i received here.

Happy flying !!!

excellent news! great to hear it’s working!