Drone Crash, need help with analyze

Hello all!,

We need help in figuring out why the drone crashed. We flew a quad, with firmware Copter 3.5.5 in a mission flight ( auto mode). After 10 minutes of flight, at height of 40 meters, the drone switched to alt hold. At this moment, the drone started to spin around itself and descend till it crashed on the ground. We use a sonar rangefinder for landing, and we set:
EK2_ALT_SOURCE = 0, EK2_RNG_USE_HGT = -1, and FS_EKF_ACTION = 2 ( AltHold).
We set rangeinder max_cm = 100 meters. We don’t use optical flow. In previous flights we got bad ekf terrain altitude variance messages. I’m attaching the log file, the parameters, and two graphs. We see a sudden spike in SS parameter (NKF4) before it changed to althold. What is exactly SS?

link for log:

link for params:


Thanks a lot!

Have a look at RCin
Seems you lost radio and your failsafes were set to minimum PWM

Why not update to 4.0.4-rc2 or at least 3.6.12?

Thanks Mike, we have looked at it and yes it seems that we lost radio. On the other hand, we set FS_THR_ENABLE = 0 ( disable throttle failsafe), so I still can’t figure out why it changed to alt hold.
It changed after more than 1 minute since pwm fell to minimum.

I noticed that when the drone turns on, it sets itself to alt hold mode. That is because alt hold is set as flight mode 1 in the rc transmitter configuration. Is it possible for the drone to change itself to flight mode 1 in a case of radio loss during a flight?
In addition, in all these sudden alt hold mode switches, there is this EKF parameter SS ( filter solution status? ) spike, which I’m struggling to understand. I will be glad to get a clarification for the meaning of that parameter.


We plan to do so…heard there is a lack of support for pwm rangefinders in copter 4.0, so we will probably switch to i2c.

Have a look at your radio.
At present all channels go to minimum so mode will change because channel 5 has gone to minimum.
Not setting your radio FS is the contributing factor.
On most good radios you can set what to do on channels when radio is lost, eg: on the JETI and Futaba I use regularly the channels are set to HOLD and throttle is set to OFF or -100%

As Mike pointed out, this seems to be a mixture between RC Disconnect and the settings on your transmitter. Personally, I have my FrSky set channels 1-4 to 50% and all other switches to hold. What I imagine is that your transmitter set all channels to min - with changed the flight mode to alt-hold as Ch5 min is associated with Alt-Hold.

I always use the ArduCopter based FS to RTL as well and I highly recommend setting that up if you can.

Thanks, I’ll take look again at my FrSky configuration.