Servers by jDrones

Drone crash at AutoTune step 4

(Jax) #1

Hello everyone,

I’m actually building a new quadcopter with 20’ props, which flies with the stock PID, but I would improve them by using the AutoTune feature.
The auto tuning seams to work pretty well at the beginning, but at the exact same phase of the tuning, the copter starts to oscillate and ends with a crash.
I’ve tried to do it with all axis at the same time, with one axis only, reducing the agressivity, tuning a bit the PID by hand before to start the autotune, doing the AT in AltHold and Loiter, etc. but it always results in oscillations and crash at the step 4 (according to the logs) of the AT procedure (by the way I can’t find the meaning of step 4 on the documentations which only talks about steps 0, 1 and 2…)

The drone I’m trying to tune is a quadcopter based on a Gryphon Dynamics frame with :

  • Pixhawk 2 Cube FC running APM copter 3.5.7
  • 20’ carbon props
  • MAD 5010 240kV Motor
  • Tmotor Flame 60A ESC

Here is a video of the AT just before the crash with the corresponding logs :

https://drive.google.com/open?id=1GfEbKDCBlsIbW7d3hFQKXAPxDpok5RcB

Do you have any advice about this strange reaction ?
What does ATUN.Step 4 means ?
Does the AT is worth or should I tune the copter manually ?

Thank you :slight_smile:

Tuning 1.4m X8, oversensitive
(Andras Schaffer) #2

Logs ?
post must be 20 character

(Andras Schaffer) #4

It does not look likes a desync, rather an oscillation went out of control.

Try
Decrease ATUNE_AGGR to 0.075 or even lower (0.06)
and set rate filters to 10Hz from 20. (Extended tuning screen in MP)
(These are the common recommendations for large copters autotune)

(Andre-K) #5

I’ve autotuned two of those Gryphons , like Andreas says, by following best practices.

(Jax) #6

Thanks for your replies

I also though it can be a filter issue, so I rapidly changed them to 10Hz, and tried different ATUNE_AGGR from 0.1 to 0.05
There is a clear difference in the time needed for the autotune, but the result still the same …

(Fnoop) #7

From the video it looks like perhaps it’s turning the PIDs up too high? Probably a question for @tridge or @lhall

(Fi156) #8

Hello,
can you provide pictures of the frame an especially from the Pixhawk mounting?

Please test for ESC desync issues on the bench.

(Jax) #9

Hi,
This is the drone used :



I’ve tested the motor/props/ESC on the bench today, and haven’t seen some desync issues.
Here is a video of this test :

(oguz) #10

Setting MOT_THST_EXPO to 0 helped in our case. I think Flame 60H already has a linear throttle-thrust curve and using a value of MOT_THST_EXPO = 0.65 messes up the linearity.