Droidplanner has stopper-Galaxy note gt-n5110

I am trying to run Droidplanner on my Galaxy and it crashes when I try to Connect. I am trying to run DroidPlanner 2.2.1. ( I also tried 1.2 with same results). I am using the 3dr 915 Mhz radio along with their supplied cable. The radio works with Mission Planner. I am using Android version 4.1.2. Any help would be greatly appreciated. Thank you

Can you check the /DroidPlaner/LogCat/ folder? Copy and paste the latest .txt. file here in the forum.

Here is the log file:

at org.droidplanner.connection.UsbConnection.readDataBlock(UsbConnection.java:37)
at org.droidplanner.connection.MAVLinkConnection.run(MAVLinkConnection.java:78)

Looks like DP is having a problem with USB.

Two tests you can make:

  • When you connect the telemetry module , via a USB OTG adapter, does a window pops upm asking to open the device with DroidPlanner?
  • When you connect the telemetry module, does the leds on the module blink as usual?
  • What happens when you connect a USB flash drive with the USB adapter?

As a alternative way to use the app, if we are not able to fix the USB, you can use a Bluetooth to telemetry board.

When I connect the telemetry module it initiates Droidplanner. The green led is flashing. When I turn on Iris the flashing green led goes solid. But then when I hit connect, it crashes. I couldn’t find a USB flash drive. Could it still be a bad cable or maybe I have another app that is causing issues? Is there a separate module for bluetooth? Thank you.

Could it still be a bad cable ?
I don’t think so, your connections look good. The flash drive test would confirm that your cable, and your tablet usb port is working correctly.

maybe I have another app that is causing issues?
I don’t think so, but your device may be lacking the necessary drivers to comunicate with the serial IC on the telemetry module. Search the forum about this issue, there can be some ways around it.

Is there a separate module for bluetooth?
There are no official BT modules from bluetooth. But you can make your own as described here:
github.com/arthurbenemann/droid … -bluetooth

Or buy something like this:
kickstarter.com/projects/69 … ablets-sma

I’m having the same problem on a Galaxy Note 8.0. Same error codes in LogCat folder as stated above. I’ve tried the app and 3DR V2 radios on a Samsung Galaxy S4 with no problems, thus the cable and the radios are both in good shape. I’ve installed the FTDI android drivers. I’ve turned on USB debugging. I’ve scoured the internets looking for the magic solution, tried everything I’ve seen (that made sense to try)… I’ve yet to succeed in connecting to the radio without the app crashing. The lights tell me the radios are connected and data is being exchanged. The app verbally says it has connected to the radio, then within a few seconds the app crashes.

Has this problem been solved yet? If anyone knows the solution, could you kindly link me to said solution’s webpage? T’would be much appreciated.


Has this problem been solved yet? I don’t think so. It’s a hard problem to solve because we don’t have the device to do the testing/debugging. My advice is to go via the Bluetooth option for the moment.