Drifting to left in PosHold on Hexa 3.5-rc4

Been out testing 3.5-rc4 tonight on my Tarot 680Pro hexacopter. Prior to the 3.5 upgrade I was running 3.4.3 and it performed flawlessly on that release. I have not made any modifications to any part of the copter (aside from installing the LED display on the i2c bus), simply upgraded to 3.5-rc4. I did perform accelerometer and mag calibrations after the upgrade.

In PosHold, with center sticks, the copter does not hold its position, but drifts to the left. Selecting Loiter mode, the copter instantly stops and holds its position perfectly as expected, but then back to AltHold mode and the drift begins again. It does allow me to reposition of course using the right roll stick, but beck to center sticks and the copter drifts leftward again. Log can be downloaded here: https://www.dropbox.com/s/w4haywan8bu5o1u/00000002.BIN

Hope this helps someone identify the issue.

Cheers, Paul

Did you check level in the mission planner hud? or try to level again, sometime ago occurs to me and solved like that.

Yes, I did the accelerometer calibration directly after the firmware upgrade. Besides, surely in PosHold this should be compensated by position error? It certainly works fine in Loiter - which is strange as PosHold isn’t working well.

I have the same problem with my Hex. I have returned to firmware 3.4.6 and all solved. Seems to remain some details to solve for the hexa in the 3.5

Good to know it’s not just me! Thanks for the post. Hopefully the log I linked will help the devs diagnose the issue.

Have seen the same thing. Sometimes it’s right on and other days it drifts to the left but will drift to the right if you turn the copter 90 degrees.


Have just updated my 330 quad (was on 3.4.6) to 3.5-rc4. Calibrated compass as instructed and once again, in PosHold it drifts to the left! This can not be a coincidence.Again the copter is more stable in Loiter, but in PosHold it instantly drifts leftward.

Oops! I have figured out the cause of the issue - rookie mistake! …which as I am not a rookie should have never happened! Turns out that my radio was commanding left aileron, hence the drift left, and loiter…well its possible there is a bigger deadband in loiter so it wasn’t effecting a drift due to that. I replaced my radio recently and even installed M9 gimbals in it, and even though I did a radio calibration on the Taranis, I forgot to check the radio calibration section in Mission planner - of course we need to ensure that center stick reads 1500 for each model… and mine didn’t! So I tweaked the sub-trims in my model outputs screen to get 1500 on A,E,R centre sticks in MP and all appears good now thankfully.

To be honest, even though I don’t have the commanded drifting issue now, the hexacopter in particular feels very different on 3.5. Its far more responsive to stick inputs. I reduced Stab P values down from 8 to 6 and also reduced RC-FEEL to 0.5 from 0.6, but still super sensitive. Think I need to run an autotune if we get a low wind day.

Great that you figured this out!

Took it for a proper flight tonight and flew really well. Usual modes tested: Stab, AltHold, PosHold, Loiter and RTL. RTL deployed landing gear as expected also. Like I said, I now have reduced Stab P values and reduced RC_FEEL as it was feeling far more sensitive to inputs on this release compared with 3.4.3. Flying nice and I’m a happy bunny :slight_smile: Thanks again Randy & co - awesome job.